Answered
0
0

FMOD crashes when running builds in the iOS simulator (Xcode v9.1, Simulator v10). There are no linking errors during the build process. I’m running Unity 5.6.4.

Has anyone seen the following?

(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

dyld: lazy symbol binding failed: Symbol not found: _FMOD5_Memory_GetStats
  Referenced from: /Users/stevensmith/Library/Developer/CoreSimulator/Devices/B2E0B1C6-3E01-40FC-BCF6-3F64756EB209/data/Containers/Bundle/Application/F5E769DC-DD00-4C91-8B92-600C9985CA14/AfaTest01.app/AfaTest01
  Expected in: flat namespace

dyld: Symbol not found: _FMOD5_Memory_GetStats
  Referenced from: /Users/stevensmith/Library/Developer/CoreSimulator/Devices/B2E0B1C6-3E01-40FC-BCF6-3F64756EB209/data/Containers/Bundle/Application/F5E769DC-DD00-4C91-8B92-600C9985CA14/AfaTest01.app/AfaTest01
  Expected in: flat namespace

Update: I’m posting the linker error described in the comment below here so that it can be formatted for easier reading

Undefined symbols for architecture arm64:
  "_FMOD_Studio_EventInstance_SetParameterValuesByIndices", referenced from:
      _EventInstance_FMOD_Studio_EventInstance_SetParameterValuesByIndices_m2967463134 in Bulk_Assembly-CSharp-firstpass_1.o
      _EventInstance_setParameterValuesByIndices_m780857556_AdjustorThunk in Bulk_Assembly-CSharp-firstpass_1.o
     (maybe you meant: _EventInstance_FMOD_Studio_EventInstance_SetParameterValuesByIndices_m2967463134)
ld: symbol(s) not found for architecture arm64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
  • Steven Smith

    Update: I had mistakenly said that 1.10 builds for the device. It does not. 1.09 builds for the device. 1.10 has a linker error when building for device.

  • You must to post comments
Best Answer
1
0

The iOS Simulator requires libs built against the Simulator SDK, which we currently do not build or supply. I have added this to our tracker and will be available in a future release.

What is the linker error you are getting with 1.10?

  • Steven Smith

    Thanks for the response. I posted the linker error as an update to the post above so that it’s easier to read.

  • Cameron Baron

    That issue has been fixed for the next release, in the mean time it is possible to work around this by commenting out the function in the fmod_studio.cs.

  • You must to post comments
0
0

Hey I am also having issues with this in an upgraded project while building for release.
I am afraid that when I comment this function out some of the audio might not work in the project. I have to release for a client this week so can anyone tell me if it is safe to comment this out?

Found using:
Unity 2017.2 (Mac)
Fmod plugin 11001_v2.unitypackage
xcode 9.1
Os: High Sierra


Update:
Downgraded to 1.09. Version builded and launched without problems.

  • Cameron Baron

    If you aren’t using the function then commenting it out should have no effect on your project.

    Otherwise, 1.10.02 is now available with the fix for this issue.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.