Answered
0
0

I am working with on a project using Unity Teams (their cloud service) and in the beginning of the project Fmod and Unity worked fine for me but since other team members integrated Fmod to be able to hear the sounds I keep getting this error:

DllNotFoundException: fmodstudio
FMOD.Memory.GetStats (System.Int32& currentalloced, System.Int32& maxalloced, Boolean blocking) (at Assets/Graphics/Plugins/FMOD/Wrapper/fmod.cs:1629)
FMOD.Memory.GetStats (System.Int32& currentalloced, System.Int32& maxalloced) (at Assets/Graphics/Plugins/FMOD/Wrapper/fmod.cs:1624)
FMODUnity.RuntimeUtils.EnforceLibraryOrder () (at Assets/Graphics/Plugins/FMOD/RuntimeUtils.cs:391)
FMODUnity.StudioListener.OnEnable () (at Assets/Graphics/Plugins/FMOD/StudioListener.cs:17)

This has resulted in them hearing the sounds, but not me. I looked around and saw that I might need Unity Pro to use it? But I don’t get why the sounds would work earlier and now only for other projectmembers then? Don’t know if it’s relevant but they are all using Windows, while I’m using Mac.

  • You must to post comments
Best Answer
0
0

Unity Pro is only required when using Unity 4, because plugins were only available to Pro users.
It looks like you are missing the required libs. The standard FMOD Unity Integration comes with both Windows and Mac libs (and plenty of others). They should be located in:
“ProjectDirectory/Assets/Plugins/*”

Simply re-import the Integration and it will give you the option of importing anything you are missing.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.