0
0

hi. has anyone had problems running FMOD 3.73 using CodeWarrior7? When using FMOD_Init(…) i am getting an error….debugger tells me its an unmapped memory error in alloc.c! Using Carbon Lib. and MSL_All_Carbon. Early version (ie FMOD 3.62) runs fine. Thanx.

  • You must to post comments
0
0

brett.

tried using proj. files from examples ƒ. Result ;

Link Error : undefined ‘_current_locale’ (data)
Referenced from ‘eatwhite’ in fmod_cfm.lib

Link Error : undefined ‘isspace’ (code)
Referenced from ‘FSOUND_Net_ParseUrl’ in fmod_cfm.lib

Its all very strange. My previous problem came from rebuilding my previous working code, moving it to fmod 373. Its clearly an obscure .lib thing. Perhaps i am missing an update of CW7. Stay tuned…….

  • You must to post comments
0
0

hi.
an update on problems. Switched to OSX and example projects work. Will test some more things out today. Perhaps Carbon in my OS9 needs updating? For now i’ll be workin’ in OSX!

  • You must to post comments
0
0

Back again.
Currently writing some wrapper classes and designing a synth framework. Have run into an old problem…..

Link Error : undefined ‘_current_locale’ (data)
Referenced from ‘eatwhite’ in fmod_cfm.lib

Using CW 7.0, in OSX, target Carbon. I only get this link error when using the call :
FSOUND_Stream_Open(….)

FSOUND_Stream_Create(…) works fine, as does loading samples and dsp stuff.

Library Files in project :
CarbonLib
fmod_cfm.lib
MSL_All_Carbon_D.Lib.

I have also tried example files. They work except for “stream” (yep. the very example that uses Stream_Open…)

Any help/clues would be great.

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.