0
0

Hi,
I’m using FMOD 3.73 on Fedora Core 2 (actually, through python).
FMOD works great, except that if I try t o initialize it while another program (xmms, for example) is already using the sound card, FMOD will hang – note that it doesn’t crash, it merely hangs, along with the rest of my program, until I close whatever is using the sound card – then FMOD continues on normally.

Is there any way to check if the sound card is in use before I try initialization?

  • You must to post comments
0
0

i have redownload 3.74 and now this works as you said.
but how can one easily distinguish between the first 3.74 and the last 3.74 version?
regards,
gunnar

  • You must to post comments
0
0

yes and so it could be quite problematic if user complains about something.
Setup programs will not overwrite files with equal versions etc.

regards,
gunnar

  • You must to post comments
0
0

I think it’s your OSS driver which doesn’t allow to work as multiple clients.
I had no problems whatsoever with ALSA and my cards

  • You must to post comments
0
0

Is this something configurable through FMOD, or is iit external to it and is something one would do through the OS, regardless of the code in my program?

  • You must to post comments
0
0

Hey thanks

  • You must to post comments
0
0

[quote="brett":3bqch02b]i’m just about to reinstall with fedora 3 so i’ll test it out soon[/quote:3bqch02b]

Watch out brett !
FC 2 crashed my harddrive so i’m working only on Windows OS atm and can’t do test either 😕

  • You must to post comments
0
0

Hello,
as said in the subject already there are a lot problems with alsa and fmod.

Some citations from my forum.
Here are the versions I have installed:
fmod: 3.71

I was able to get v3.0.2 installed using the ebuild and patch from this site:

http://www.breakmygentoo.net/cgi-bin/vi … d/wxMusik/

Love the program! ALSA Freezes, but OSS works fine. Looking forward to the new features in 3.1.0!

another one:
ust a note about fmod on linux… on my system it will not work using ALSA as the output, only OSS. Also wxMusik is using my soundcard even when I’m not playing a song. So even if I press stop, I need to shut down wxMusik to play any other sounds (my soundcard drivers can’t do simultaneous sounds). Not sure if that’s because of wxMusik or fmod….

bug reports:
Original Submission:
Switched to Alsa output
Musik immedieatly crashed
says segmentation fault when I attempt to launc

Followups

Comment Date By
I also get this error. Musik crashes when I try to play a song with ALSA and dumps core files.
The only driver that works for me is ESD.
I’m using kernel 2.6.5 and alsa-lib 1.0.3b. 2004-May-13 01:28 kristinnm
this is the problem?
kernel 2.6 – alsa1x
fmod – alsa9

  • You must to post comments
0
0

So i gave it a try. and now alsa works :-)

actually it did not work at first because in my own code there was an if condiditon the prohibited to call SetDriver with 0.
Funny enough that work with oss, win32 and macosx

Would it be possible to make a static lib for linux? like for osx?

regards,
gunnar

  • You must to post comments
0
0

well, it did NOT work with out calling SetDriver()

now it works on linux with alsa and oss .
windows i have to test , maybe that will make problmes.

what about static library for linux?
regards,
gunnar

  • You must to post comments
0
0

It’s absolutely great that you fixed the alsa problems, thanks a lot!

  • You must to post comments
Showing 10 results
Your Answer

Please first to submit.