0
0

Not sure if this is known or is even a bug but I’ll post it here anyhow.

I recently added support to my player for mods,s3ms, xms, ect. What I am noticing is that when a song ends and the window is not in focus, ie not the active window, and the next song kicks in whatever window is the active window gets control of the sound. I do not use or set any hwnd for fmod, and I want the sound to be global throughout windows.

For example I start my player, give it a playlist, and go surfing, 1 song ends and the next starts, when i go back to my player the sound stops, when i go back to my browser the sound resumes, any ideas?

++Cire.

  • You must to post comments
0
0

I thought you might need some further details on my player. On the end/start of each song i shutdown fmod completely and restart it freeing all resrouces and whatnot cleaning itself up, ect..

Then I reinit and play, this seems to work very well, however if i’am busy in another window and the song ends, when it inits it seems to be locked to the hwnd of whatever window i’am in, if i goto any other window but my player I can hear the song just perfectly. However when i shell to the player I can’t hear it yet I can see the VU meter changing as well as fft display, ect.

I was wondering if perhaps I should set the hwnd, and then after it starts playing set to 0? Or would this be asking for trouble? Any ideas or suggestions? Does anyone else experience this bug, btw I also tested this with streams on mp3’s and the same thing happens.

Anyhow tahnks in advance.

++Cire.

  • You must to post comments
0
0

Thanks a bunch, if we ever meet I owe ya a beer. :smile:

++Cire.

  • You must to post comments
0
0

Brett>i ve noticed that loading a stream with FSOUND_ENABLEFX disable FSOUND_INIT_GLOBALFOCUS, the sound continue to stop, even using FSOUND_SetHWND(hWnd) or not, is it a bug ?

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.