0
0

I am statically linking fmod and to get filesize down I disable a number of features I don’t use.

With the latest version (3.74) when I disable 3DSOUND it does not link successfully. It is missing the function FSOUND_Software_Channel_Update. Apparently that is used by DSOUND whether or not 3DSOUND is used.

I disabled 3DSOUND by commenting out this line in system_settings.h:

//#define FSOUND_SUPPORT_3DSOUND

but, still want to use DirectSound for low latency playback, so I keep this:

#define FSOUND_SUPPORT_DSOUND

Alas, it will not link.

-Garr

  • You must to post comments
Showing 0 results
Your Answer

Please first to submit.