0
0

Hello !

I have a wav file saved with the actual lame encoder as mp3 file.
The wav file was a loopable sound. But the resulting mp3 file has
a short silence at the start and end which makes it not useful for
looping any more :(

I read in other forums that this silence is caused by the definition
of the mp3 format :

[quote:2xtgtf4n]You can’t use MP3 for loops as the header information in the file (which contains the ID3 tag info) pads out the file. This is the ‘silence’ that appears at the start of the loop when you look at it in an audio editor.

I spent a whole evening ‘editing’ gaps from an Acid project I’d done in MP3 loops (because I needed to send it to someone without much disc space) only to find they re-appear when you re-load them. Doh!

Whether this applies in other compressed formats, I don’t know (ogg, MP4/aac etc) – I decided it’s safer to stick to wav as the default.[/quote:2xtgtf4n]

[quote:2xtgtf4n]The extra added silence is part of the MP3 definition. Don’t use MP3 for loops; save them as WAV instead.[/quote:2xtgtf4n]

So what should I do now ? The wav file is to big for my application
purposes…the resulting mp3 is small and of high quality but not
useful for looping. Are there any “features” in FMOD to play such an
mp3 as loop BUT ignoring the mentioned silence ?

Thx for help/suggestions ! :)

  • You must to post comments
0
0

There is a flag to ingnore tags in files or you could open the mp3 in an application that can edit tags and remove them (most decent players will do the job).

  • You must to post comments
0
0

ogg is a gapless format which should help with this (its much better quality as well)

  • You must to post comments
0
0

thanks for your ideas, which is the best free encoder for ogg ? :)
(like lame is for mp3)

[b:3ous91kj]edit[/b:3ous91kj]
I just found out that this is ogg vorbis encoder
(maybe it’s also the only one dunno)

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.