0
0

Hello,

I’m trying to get several different streams playing out of 1 asio card on different outputs(terratec phase 28 ). I’m using VB and tried to copy the fmod.dll to fmod2.dll and renamed all functions. The second fmod is working by itself but when initialising both, the second one won’t work.
When starting fmod2 first fmod isn’t working…..

Maybe because setoutput is set to the same card???

Does anyone have a solution or do I have to wait for fmod ex?

greetings

Remco

  • You must to post comments
0
0

I’ve never played with ASIO outputs, so I’m not 100% sure, but you should take a look at FSOUND_GetNumHWChannels, FSOUND_SetMinHardwareChannels and FSOUND_SetMaxHardwareChannels.

  • You must to post comments
0
0

I think I’ve tried to do that, but de number of HW channels returned was zero. I’m not shure, I’ll go and try it again… thanks for the hint!

  • You must to post comments
0
0

Brett,

That sounds very cool!! Exactly what I need! Just waiting for the fmod ex beta to be available.

Thanks,

  • You must to post comments
0
0

have you set the output driver to asio?

  • You must to post comments
0
0

Your terratec ASIO dialog should have a option for “multi-client mode” this allows each output to work seperate.

  • You must to post comments
0
0

The output is set to ASIO and I can drive every output separately with one fmod, so that’s not the problem.

I have set the Terratec to multi-client mode, but that doesn’t seem to solve the problem. The second fmod still won’t initialize, but gives an error upon init.

Remco

  • You must to post comments
0
0

I’ve double checked it with my Terratec cards and you’re correct.

Actualy i have 2 terratecs which both use the same asio driver (Asio88mt.dll v5.44.3.134)

If i select several channels from both cards only 1 works,
The other soundcard plays dead and from the 1 card only 2 channels playback.

I will go check with FMOD-Ex when i have the time if it is a Terratec or FMOD issue

  • You must to post comments
0
0

The strange this is that when I set the first fmod to ASIO and don’t set the second (i.e. it uses the WDM), both fmods work. But I have 4 stereo outputs that i want to use instead of two.

Remco

  • You must to post comments
0
0

This is perfectly normal, as only a single application can use the ASIO driver at any given time. This is unrelated to either FMod or Terratec, and is “built-in” into the ASIO standard.

  • You must to post comments
0
0

Ok,

but how can I get two (or more) streams out of different outputs at the same time with fmod?
Remco

  • You must to post comments
0
0

Ok,

but how can I get two (or more) streams out of different outputs at the same time with fmod?
Remco

  • You must to post comments
Showing 11 results
Your Answer

Please first to submit.