0
0

I am trying to play a sample in surround sound mode, but there is only sound from the front two speakers. What am I missing?

//App Name: Surround_Test.exe
//Compiler: Visual Studio 6, Service Pack 6

pragma comment(lib,”fmodvc.lib”)

include “fmod.h”

include “fmod_errors.h”

include <conio.h>

include <iostream>

include <iomanip>

include <fstream>

using namespace std;

FSOUND_SAMPLE *sample;
int channel;

void main()
{
if (FSOUND_GetVersion() < FMOD_VERSION)
{
throw “You are using the wrong FMOD DLL version”;
}

FSOUND_SetMixer(FSOUND_MIXER_AUTODETECT);

FSOUND_SetSpeakerMode(FSOUND_SPEAKERMODE_SURROUND);

if (!FSOUND_Init(44100, 8, 0))
{
    cout &lt;&lt; "FMOD Could not be Initialized... Terminating\n\r";
}

FSOUND_3D_Listener_SetAttributes((0,0,0), (0,0,0), 0, 0, 1.0f, 0, 1.0f, 0);

sample = FSOUND_Sample_Load(FSOUND_FREE, "./machine_ring_resonance_loop1.wav", FSOUND_LOOP_NORMAL, 0, 0);

channel = FSOUND_PlaySoundEx(FSOUND_FREE, sample, NULL, true);

FSOUND_3D_SetAttributes(channel, (0,0,0), (0,0,0));

FSOUND_SetSurround(channel, true);

FSOUND_SetPaused(channel, false);

edit forgot this line:
FSOUND_Update();

cout &lt;&lt; "Playing Sample...\n\r";

while(!kbhit())
{

}

cout &lt;&lt; "Finished Playing Sample...\n\r";

FSOUND_Sample_Free(sample);

FSOUND_Close();

cout &lt;&lt; "Exiting...\n\r";

}

  • You must to post comments
0
0

[quote="brett":nhrvjkb2]you should test your surround sound setup by setting the speaker mode in your control panel/speaker settings[/quote:nhrvjkb2]

What do you mean by “setting the speaker mode”?

I tested my setup with the utility that came with the card, and each speaker was correct. WMPlayer playes in 3D.

  • You must to post comments
0
0

OK. in win 2K, I found this and set it to surround 5.1

[img:3h8tezxw]http://img2.uploadimages.net/277386SoundPropertiesCapture.jpg[/img:3h8tezxw]

I still do not have surround….

  • You must to post comments
0
0

OK. I moved the sound out of (0,0,0) and the front two speakers are responding normally. All the rest are totally silent (In the app, they work notmally elsewhere…), I am running the latest driver (reinstalled several times…). What else can I do โ“ Does the listener have to be out of (0,0,0) as well โ“

  • You must to post comments
0
0

OK, I got it working(Somewhat… ๐Ÿ˜• ) If I load it with the HW3D flag, it will play in surround… But I cannot use more chanels than 3D hardware channels that I have(16), where I need at least 64 channels…. โ“

  • You must to post comments
0
0

General Question, When I use the HW3D flag, is all the processing done in hardware, software, or both?

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.