0
0

[b:2t985gag]System:[/b:2t985gag] kernel 2.6.11.7, ADI AD1980 SoundMAX sound card, fmod 3.74, SDL 1.2.8.
[b:2t985gag]Error:[/b:2t985gag] “FMOD could not start – Error initializing output device.”
[code:2t985gag]
FSOUND_File_SetCallbacks(&Sound_Open,
&Sound_Close,
&Sound_Read,
&Sound_Seek,
&Sound_Tell);
FSOUND_SetMinHardwareChannels(16);
FSOUND_SetOutput(-1); // auto-select
FSOUND_SetDriver(0); // default
FSOUND_SetMixer(FSOUND_MIXER_AUTODETECT);
FSOUND_Stream_SetBufferSize(2000);

if(!FSOUND_Init(44100,32,0)) {
Error2("FMOD could not start – %s\n",FMOD_ErrorString(FSOUND_GetError()));
FSOUND_Close();
}
[/code:2t985gag]
[b:2t985gag]Question:[/b:2t985gag] What is going wrong?

  • You must to post comments
0
0

try removing all of the statements before fsound init and see if it works, if it does put them back in one at a time to see which is causing the problem

  • You must to post comments
0
0

[code:3if9k2w3] FSOUND_File_SetCallbacks(&Sound_Open,
&Sound_Close,
&Sound_Read,
&Sound_Seek,
&Sound_Tell);
FSOUND_SetMinHardwareChannels(16);
//FSOUND_SetOutput(-1); // auto-select
//FSOUND_SetDriver(0); // default
//FSOUND_SetMixer(FSOUND_MIXER_AUTODETECT);
FSOUND_Stream_SetBufferSize(2000);

if(!FSOUND_Init(44100,32,0)) {
Error2("FMOD could not start – %s\n",FMOD_ErrorString(FSOUND_GetError()));
FSOUND_Close();
}[/code:3if9k2w3] Commenting out those three lines fixed the problem which is odd because I thought they were redundant default options, anyways. What did I miss?

  • You must to post comments
0
0

from the fmod docs:
[code:1vni2w1v]It is not nescessary to set the mixer. FMOD will autodetect the best mixer for you.

FSOUND_MIXER_AUTODETECT /* CE/PS2/GC Only – Non interpolating/low quality mixer. */
[/code:1vni2w1v]
autodetect is not valid on linux, only win ce, ps2 and game cube

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.