0
0

There are times when I want a specific 3D sound effect to not be 3D. Basically I have gun shots from surrounding AI bots, but I want the player’s gunshot (same sound effect) to be played normally with adjusted volume from all speakers equally.

After calling FSOUND_PlaySound, I tried not setting FSOUND_3D_SetAttributes completely, setting FSOUND_3D_SetAttributes’s pos to NULL, and also tried playing around with min and max distances. But, when the player shoots while strafing, or worse, moving forward, the sound gets warped. Standing still works great. I’m not using velocity and although it would make more sense, I think the sounds would still get warped. I was looking through the docs, and it seems as if I have to load the sound in twice, but with different flags(?).

While I’m asking, is there any way to set a minimum volume of a 3d sound? I stand directly beside a bot with my back turned, but the sound is not played. I hope it’s not possible with only 4+ speakers b/c I’m using headphones. Thanks in advance.

  • You must to post comments
0
0

Thanks a lot for the fast response. I managed to get both problems fixed very easily by only adding onto the sound manager in my game – [url:2clpf3z4]http://dxelliot.tripod.com/[/url:2clpf3z4]. My sound settings weren’t set to headphones btw.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.