0
0

Hello!
I load a mp3 with [color=yellow:3uquhd3w]systemA.createSound(tema, FMOD.MODE.SOFTWARE | FMOD.MODE.CREATESTREAM | FMOD.MODE.ACCURATETIME, ref soundA);[/color:3uquhd3w] (5:00 minutes).

When I set [color=yellow:3uquhd3w]soundA.setLoopPoints (1000, FMOD.TIMEUNIT.MS, 1100, FMOD.TIMEUNIT.MS);[/color:3uquhd3w] and play, this begins from 0 until 1100 ms and loop to 1000, but channelA.getPosition displays that the time keeps advancing, however the sound is doing the loop from 1000 up to 1100…
That is it happening?

  • You must to post comments
0
0

I test with channelA.setLoopPoints and not work. The sound keeps advancing, not loop, but the time (channelA.getPosition) loops (?) 😮

  • You must to post comments
0
0

You need to create (or set the mode) the sound with FMOD_LOOP_NORMAL (FMOD.MODE.LOOP_NORMAL in c#).

  • You must to post comments
0
0

Tanks, but not work…

  • channelA.setLoopPoints shows the loop in getPosition, but the sound continues without loop.

  • soundA.setLoopPoints makes the loop work, but getPosition keeps advancing.

The only way that works correctly (time and sound) is using:
channelA.setLoopPoints and soundA.setLoopPoints (both).
Like this it is as it must be used?

  • You must to post comments
0
0

I am unable to reproduce this problem you are having.

Have a look at the createStream example and add the line
[code:tfot2u69] result = sound->setLoopPoints(1000, FMOD_TIMEUNIT_MS, 1100, FMOD_TIMEUNIT_MS);
ERRCHECK(result);[/code:tfot2u69]

after the createSound (add FMOD_LOOP_NORMAL if it isn’t already there).

This works without any problems.

  • You must to post comments
0
0

Another question…
Once I set setLoopPoints, as I do to disable it?

Tanks!

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.