0
0

I am using my own file system, streaming, unicode, and in hardware. When I play a sound as 2D it works fine. If I play a sound as 3D I hear nothing. I am setting the system position to 0.0f, 0.0f, 0.0f and the velocity to 0.0f, 0.0f, 0.0f. The sound position is also set to 0.0f, 0.0f, 0.0f.

More info. It seems that the file is being read very slowly compared to 2D mode, dont know if that helps.

BTW the 3D test app works fine.
Any ideas?

  • You must to post comments
0
0

All things being equal. My app works if I set the FMOD_SOFTWARE flag instead of FMOD_HARDWARE when calling createsound.

  • You must to post comments
0
0

Might be a driver issue; I tried hw3d sounds yesterday and the OS bluescreened on me. A driver update worked.

I did notice the software method gave louder sounds than my particular sound hardware (an onboard AC97 CMedia). Other than that it works. You might want to try offsetting the sound position by 0.1 or so, perhaps it’s TOO close?! (div0)

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.