0
0

I stream an ogg file (mp3 too) from the internet (http protocol), and the last 2 seconds of the song are cut off always. For example, I have an ogg filer with exact 2 minutes length, fmod stop playing it after 1:58, so it sounds not good. Any idea what could case this??? I played already around with buffers etc., but no result/changes regarding this.

  • You must to post comments
0
0

I have corrected the fmod.pas and fmodtypes.pas and now it compiles and works with delphi 5 without error or warning.

  • You must to post comments
0
0

In line 572 in fmodtypes.pas, the line

FMOD_OPENSTATE_READY = 0,

changed to

FMOD_OPENSTATE_READY,

and in line 843

PInteger

changed to

^Integer

Maybe with D7 it will work, but not with D5

Also, the const lines starting at line 474 gives errors, because if MSWINDOWS is not defined and LINUX is also not defined (like it is with my standard D5 installation), the next function would be included in the const section. So I just added at the top {$define MSWINDOWS}

  • You must to post comments
0
0

[quote="brett":h620z3z8]do you have a url we could try.

I assume you’re talking about FMOD 3?[/quote:h620z3z8]

Yes, fmod 3.

There are 2 test files:

http://www.ssdnet.biz/stream.ogg (4MB)

http://www.ssdnet.biz/test.ogg (just 2 seconds)

  • You must to post comments
0
0

The definition of MSWINDOWS was introduced with delphi 6 and starting from delphi 6, mswindows is defined in all following delphi versions.

For delphi 5, you could use the WIN32 definition, so you could add in the fmod.inc

{$IFDEF WIN32}
{$DEFINE MSWINDOWS}
{$ENDIF}

You did it there already, but if will define MSWINDOWS only, if FPC is defined (whatever that is).

  • You must to post comments
0
0

Another example stream:

http://www.ssdnet.biz/count.ogg

Its a count from 1 to 20. Played from harddisk, it counts fine to 20, played as http stream, it stops at 17. ANY IDEA? Looks like is only with http streaming, NOT from harddisk.

Example:

If currentsong below is harddisk file, it plays fine, if it is http://, it cut 2-3 seconds from the ogg file above.

stream := FSOUND_Stream_Open(pchar(currentsong),0,0,0);
channel := FSOUND_Stream_Play(FSOUND_FREE,stream);

  • You must to post comments
0
0

Here are headers which should (not tested) work with all delphi versions starting from delphi 5.

[url:3t06yxxm]http://www.ssdnet.biz/fmod_headers.rar[/url:3t06yxxm]

  • You must to post comments
0
0

ANY help regarding this matter?

  • You must to post comments
0
0

Any solution or suggestion please?

  • You must to post comments
0
0

[quote="brett":3wnat5pe]apologies. please try this dll

http://52.88.2.202/files/fmod.dll[/quote:3wnat5pe]

I tried, exact the same result. It stops at 17 if I play the count.ogg from my server. From disk, it is also ok, counts until 20.

  • You must to post comments
0
0

Brett, any quick help?
It drived me crazy that always 2-3 seconds are cut at the end.
I was thinking already that my function is maybe not correct, so I replaced the fmod call with bass calls (ahem… I dont like bass, but for testing ok)… and if played fine the stream, until the end.

  • You must to post comments
0
0

[quote="brett":n9da34yu]you could also try the FMOD Ex API. The problem with fmod 3 is it is old and hard to change, but the FMOD Ex api is really flexible and also with its more advanced streaming engine plays those count files perfectly.
I just made a new version which will be also going public in a few days with some added internet streaming functionality.
Its worth trying out.
http://52.88.2.202/files/fmodapi40036w … taller.exe[/quote:n9da34yu]

Thank you for your help, I’ll try it with the buffersize in a while and will report what happen.

I tried to download the installer above, but get a “file not found”.

  • You must to post comments
0
0

[quote="brett":2c6vk6ov]oops it hasnt got a 32 in it.

http://52.88.2.202/files/fmodapi40036win-installer.exe[/quote:2c6vk6ov]

Download is fine, thanks, will play around with it.
What I need is just ogg playback/streaming, as small as possible, so I dont know if the new fmod ex will not blow up the exe. Its a pity that there is not just a fmod ogg, without mp3/wav etc. just for ogg, small, handy.

I tried your suggestion with the buffersize, AND IT WORKS!!!! with the last fmod 3 dll in this post, it counts fine to 20 now. Without setting the buffersize, it stops at around 17. Thank you very much!

  • You must to post comments
0
0

[quote="brett":26kslfz9]oops the fmod ex version i uploaded was a dev version and had a fairly nasty bug in it stopping certain sound types from loading, i’ve just uploaded it again.[/quote:26kslfz9]

Thanks, but I cant use the dll with delphi. The headers included just gives endless errors, so I have to stay with fmod 3, unfortunately. I dont understand why you dont support delphi anymore, because delphi is one of the major languages. I can say that, because nearly 90% of my programming projects which I get from US clients are in delphi, just 10% in C/C++. I guess, anybody will write in the future some working delphi header, so I use fmod 3 until then.

  • You must to post comments
Showing 13 results
Your Answer

Please first to submit.