0
0

I cant get createDSPByType with winamp plugins to work, it shows the plugin but looks like no audio is sent to the plugin. Works just fine with FMOD.OUTPUTTYPE.DSOUND but not in ASIO

FMOD built in DSP effects like chorus works with ASIO.

Mabey the problem is wrong samplerate/bitrate for the WinAmp plugin, the plugin says that (Samplerate or resulotion is wrong use 44.1kHz 16bit)

But I have this line of code before init:

result = system.setSoftwareFormat(44100,FMOD.SOUND_FORMAT.PCM16 ,4,0);

And my ASIO settings for the soundcard is 44.1 and 16bit

  • You must to post comments
0
0

On playback of audiofiles that work.

But the problem is recording. I must set “exinfo.numchannels” to 4 otherwis I get error when createSound (se my post above)

What I want to do is take input 1&2 from soundcard “record” add DSP and “play” it on output 1&2 on the soundcard. With ASIO I get almost non latency at all, wich I like…

  • You must to post comments
0
0

OK, did some more tests.

I called getSoftwareFormat after init and get this back:

samplRate: 44100
format: PCMFLOAT
numOut: 4
m_numMaxIn: 8
m_bits: 32

How can I change to 16 bit ? The plugin like that better…

  • You must to post comments
0
0

Yes it works in default mode, or when I set it to system.setOutput(FMOD.OUTPUTTYPE.DSOUND).

But I must use “setSoftwareFormat” like this:

result = system.setSoftwareFormat(44100,FMOD.SOUND_FORMAT.PCM16 ,2,0);

otherwise the plugin complaine about smplerate/bit

I have tried on several WinAmp DSP plugs and non work in ASIO mode, here is the plugin I use (it’s a great dsp prosesor)

http://www.soundsolution.it/index.php?o … ilecatid=4

  • You must to post comments
0
0

If I don’t set system.setSoftwareFormat(44100,FMOD.SOUND_FORMAT.PCM16 ,2,0); in default (Dsound) mode the plugin complain, no other winamp dsp plugin will work without “setSoftwareFormat”

I know it’s confusing because getSoftwareFormat says it 16bit, PCM16 even before I setSoftwareFormat.

Please try the plugin, I need this… :-)

  • You must to post comments
0
0

I have 44100hz & 16bit bit in my ASIO control panel.

getSoftwareFormat reports this:

samplRate: 44100
format: PCMFLOAT
numOut: 4
m_numMaxIn: 8
m_bits: 32

Is there a way to convert to 44100 / 16 bit befor sending signal to WinAmp plugin ? Think that’s easier that get all blugins to support 48k..

  • You must to post comments
0
0

Ok, so the plugin is sent 48000 and 16 bit? just so I know before contacting the plugin athor.

Do you have a link to WinAmp plugin that accetp 48k, just so I can test with my ASIO card?

Thanks!

  • You must to post comments
0
0

I contaced the author, so lets see…

I found a plugin that is a “dsp stacker” but also have a option that force signal to 44.1, but still nothing (in ASIO mode)…

http://www.winamp.com/plugins/details.php?id=128742

I aslo tried these dsp, both only work in Dsound mode

http://www.winamp.com/plugins/details.php?id=104516
http://www.winamp.com/plugins/details.php?id=81361

  • You must to post comments
0
0

“good” That maby get some plugin (the stacker) to work, lets see.

Another ASIO question.

Can I add dsp (FMOD dsp) on a input source separate for each channel, then get the “mono” channel play on a stero output.

I have got input routing direcly to output via FMOD dsp working (realy cool with 3ms delay in ASIO)

  • You must to post comments
0
0

Thanks!

I have to test it later today, I get back to you.

  • You must to post comments
0
0

Now I have tested 4.00.36 and it works in a way. But not as I like it to.

If I just init asio

[code:21tf6xld]result = system.setOutput(FMOD.OUTPUTTYPE.ASIO);
result = system.setDriver(3);
result = system.init(32, FMOD.INITFLAG.NORMAL, (IntPtr)null);[/code:21tf6xld]

then create sound and add WinAmp DSP and starts play it works, but sounds very much like mono.

But! My MAYA 44 USB is 4 channel in and 4 channel out and if I set to mulitspeaker like this:
[code:21tf6xld]result = system.setSoftwareFormat(44100,FMOD.SOUND_FORMAT.PCMFLOAT ,4,4);[/code:21tf6xld]

or like this:
[code:21tf6xld]result = system.setSpeakerMode(FMOD.SPEAKERMODE._4POINT1); [/code:21tf6xld]

the DSP only process on one channel (on front output and not at all on rear out)
And when I start recording and play that stream directly with dsp I only get dsp prosessing on one channel. This is how I do rec and direct playback:

I must init like this otherwise is sounds like a tincan.

[code:21tf6xld]result = system.setSoftwareFormat(44100,FMOD.SOUND_FORMAT.PCMFLOAT ,4,4);[/code:21tf6xld]

Init rec, note that I must set “numchannels” to 4, else I get error.

[code:21tf6xld] FMOD.CREATESOUNDEXINFO exinfo = new FMOD.CREATESOUNDEXINFO();
FMOD.RESULT result;

        exinfo.cbsize           = Marshal.SizeOf(exinfo);
        exinfo.numchannels      = 4;
        exinfo.format           = FMOD.SOUND_FORMAT.PCMFLOAT;
        exinfo.defaultfrequency = 44100;
        exinfo.length           = (uint)(exinfo.defaultfrequency * 2 * exinfo.numchannels * 5);


        result = system.createSound(null, (FMOD.MODE._2D | FMOD.MODE.SOFTWARE | FMOD.MODE.OPENUSER), ref exinfo, ref soundRec);
        ERRCHECK(result); [/code:21tf6xld]

Start rec/playback

[code:21tf6xld]FMOD.RESULT result;

        result = system.recordStart(soundRec, true);
        ERRCHECK(result);

        //Play...
        result = soundRec.setMode(FMOD.MODE.LOOP_NORMAL);

        ERRCHECK(result);

        result = system.playSound(FMOD.CHANNELINDEX.REUSE, soundRec, false, ref channelRec);
        ERRCHECK(result);[/code:21tf6xld]

BTW, I got an 48k version of the WinAmp dsp from the autor, I tried that befor installing the new FMod, but still not working.

Help…

  • You must to post comments
0
0

Sorry for missleading last post. No I dont to process 4 channels,
only “normal” stereo.

But how do I set FMOD to handle just channel 1 & 2 in (L&R) working with output 1&2 (L&R) Rec and play.

Bwt, can I this card in ASIO as two separate cards (ch 1&2 as one, and ch 3&4 as one) ?

New step is get my Terratec EWS 88, working (it has 8 in and 8 out…)

  • You must to post comments
Showing 11 results
Your Answer

Please first to submit.