No sooner do I get my .mp3 app working with Visual Studio 2003, the boss has us upgrade to the Windows Mobile 5.0 & Visual Studio 2005 Beta combo. Of course, the app no longer works.

The original .exe runs fine with the wce/smartphone/fmodce.dll

The new 2005 produced .exe crashes with a TypeLoadException

Anyone working with the new VS.NET?

Wrestling with an ActiveSync Error that won’t allow me to deploy from VS.NET 2005. Seems to be happening with a lot of folks.

If I manually drop the files in the folder on the PocketPC (same as I did with the VS 2003 version) the error I get says can’t find the fmodce.dll even though it is right there. Copying to \windows\ doesn’t help.

Looks like a DLL registration problem and since .cab deployment isn’t happening yet that’s a problem.

[update 2]
You’ll need this to deploy to PocketPC after installing VS.NET 2005 Beta:
http://www.microsoft.com/downloads/deta … laylang=en

I’ve got deployment and the program starts, but no sound yet.

Brett, is FMOD working with Mobile 2005 Beta? If not we’ll go back to 2003 for the sound portion of our development.


  • You must to post comments


I’m working with VS.NET 2005 Beta2 right now (therefore CF 2.0) and I want to target Windows Mobile 2003, WM2003 SE and if possible Windows Mobile 5.0 devices. I need to play MP3 files in this three platforms.

I can’t get any example with fmodce.dll to work!!! I understand fmodmanaged library is for Winforms desktop applications.

Could somebody please send me a little C# code example for playing a MP3 file in an iPAQ and detailed instructions about where do I have to place fmodce.dll? I’ve placed it under \Windows directory, but do I have to include it in my project, deployi it to the same directory……..?

I need urgent reply please.

Thanks very much in advance.

  • You must to post comments

I finally had the good idea of targeting PPC2003 with a CF 1.0 project and my code finally worked.

I yesterday spent all the day testing CF 2.0 projects with the same code but didn’t work.

Now I understand that fmodce.dll is not prepared for CF 2.0. But why? If I’m externally importing DLL’s from my code this way,

[DllImport(“fmodce.dll”, EntryPoint = “FSOUND_Stream_Play”)]
public static extern int FSOUND_Stream_Play(int channel, IntPtr stream);

I just make calls to external DLL’s located at PPC, that’s why I don’t understand why it doesn’t work. CF 2.0 treats this external call in another way?

Could anybody please give me an opinion around this issue? Or has anybody solved this problem I’m suffering?

Thanks very much in advance.

In that case, I have a question for you:
my iPAQ has both CF 1.0 and CF 2.0 installed on it

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.