0
0

Take a look at the following snippet

<code>

include <windows.h”

include “fmod.h”

const char *pFilePath = “sample.wav”;
FSOUND_Init(44100, 32, 0);
FSOUND_SAMPLE *pSample = FSOUND_Sample_Load(0, pFilePath, FSOUND_FORCEMONO | FSOUND_2D, 0, 0);
for (int i = 0; i < 10; i++)
{
int channel = FSOUND_PlaySound(FSOUND_FREE, pSample);
while (FSOUND_IsPlaying(channel))
{
FSOUND_Update();
Sleep(1);
}
}
FSOUND_Close();
</code>

I know that the file I am using snaps clearly with itself, I can hear this in the sound editor I am using. But when I play it with the code above, one can feel the pause between two FSOUND_PlaySound calls.

It doesn’t matter if I use fmod samples or streams. I tried them both and the pause is still hearable.

I know I can use the looping flag, but thats not the situation. I want to be able to sequently play two different sounds (which I know snap perfectly) with no pause between them.

Any ideas how can I do this? Any ideas why the pause accures in the code above?

Thank you all in advance.

  • You must to post comments
Showing 0 results
Your Answer

Please first to submit.