0
0

I have some problem with sound playback on SoundBlaster Live! 24-bit, probably a driver problem (using the latest driver: Creative Sound Blaster Live! 24-bit and Sound Blaster Audigy LS driver 1.04.0055 ) but maybe not. It is a little strange anyway.

In our game when an event is started every sound has stopped (even a music played outside in winamp). Then i started to test FMOD outside the game in an other computer (with the same driver version).

I found that the car event example doesn’t play correctly in the designer. When the parameters are changing the sound suddenly gets noisy then stops and kills every sound on the card (winamp/movie player’s sound too) when I stop the event the winamp/movie sound is on again but noisy. Then when i exit from the designer the sound is correct again (no noise).

If i set the wavebank to force software(after played in hardware) the sound plays but is noisy. If I start it in software mode it works perfectly.

I think I should write to Creative but you are much more responsive. ๐Ÿ˜‰

  • You must to post comments
0
0

I played a little more with the car event in the designer.
It seems like the sound fading/mixing causes the problem. If i just move the rpm/load param when only one sound should be played it is ok(autopitch works), but when two sounds should be mixed it gets noisy and stops. After restarting the sound (stop then play) it is noisy even where it was ok in the first start.

if I can help in anything /test something/ let me know.

thx

The caps:
Sound Blaster Live! 24-bit (P17.sys)
dwMinSecondarySampleRate 4,000
dwMaxSecondarySampleRate 96,000
dwPrimaryBuffers 1
dwMaxHwMixingAllBuffers 64
dwMaxHwMixingStaticBuffers 64
dwMaxHwMixingStreamingBuffers 64
dwFreeHwMixingAllBuffers 63
dwFreeHwMixingStaticBuffers 63
dwFreeHwMixingStreamingBuffers 63
dwMaxHw3DAllBuffers 64
dwMaxHw3DStaticBuffers 64
dwMaxHw3DStreamingBuffers 64
dwFreeHw3DAllBuffers 63
dwFreeHw3DStaticBuffers 63
dwFreeHw3DStreamingBuffers 63
dwTotalHwMemBytes 0
dwFreeHwMemBytes 0
dwMaxContigFreeHwMemBytes 0
dwUnlockTransferRateHwBuffers 0
dwPlayCpuOverheadSwBuffers 0
General
dwMinSecondarySampleRate 4,000
dwMaxSecondarySampleRate 96,000
dwPrimaryBuffers 1
dwMaxHwMixingAllBuffers 64
dwMaxHwMixingStaticBuffers 64
dwMaxHwMixingStreamingBuffers 64
dwFreeHwMixingAllBuffers 63
dwFreeHwMixingStaticBuffers 63
dwFreeHwMixingStreamingBuffers 63
dwMaxHw3DAllBuffers 64
dwMaxHw3DStaticBuffers 64
dwMaxHw3DStreamingBuffers 64
dwFreeHw3DAllBuffers 63
dwFreeHw3DStaticBuffers 63
dwFreeHw3DStreamingBuffers 63
dwTotalHwMemBytes 0
dwFreeHwMemBytes 0
dwMaxContigFreeHwMemBytes 0
dwUnlockTransferRateHwBuffers 0
dwPlayCpuOverheadSwBuffers 0
General Caps
DSCAPS_PRIMARYMONO Yes
DSCAPS_PRIMARYSTEREO Yes
DSCAPS_PRIMARY8BIT Yes
DSCAPS_PRIMARY16BIT Yes
DSCAPS_CONTINUOUSRATE Yes
DSCAPS_EMULDRIVER No
DSCAPS_SECONDARYMONO Yes
DSCAPS_SECONDARYSTEREO Yes
DSCAPS_SECONDARY8BIT Yes
DSCAPS_SECONDARY16BIT Yes

  • You must to post comments
0
0

Hi!

I checked the FMOD Designer 1.02.00 and the problem still exists,
but it works much better now. :)

I tested it with the car event again.
In the FMod Engine Designer window if i change RPM slider’s value the sound works perfectly (it is bad on the earlier version 1.01.07) .

But if I set RPM smooth to a large value and then changing the RPM slider’s value the sound gets noisy and stops.

If I set the RPM smooth parameter to zero while the load parameter is changing the sound stops.

When I directly set the RPM paremeter(no matter how slow i tried) the sound still gets noisy and stops when gets to a mixing area.
But can be heard again when the rpm is increased and gets out of the mixing area (but it is still noisy).

Have you got any answer from Creative?
Does anyone have similar problems?

Thx

  • You must to post comments
0
0

Hi!

Creative sent us a Sound Blaster Audigy SE, but we have the same (or at least similar) problem like with Live 24!.

When I play the car event it kills every sound except that comes from the front center speaker. (In 5.1 setup).

I made the event as simple as possible, and i even recreated the event from scratch. It is simply: two sound cross fading in the same layer in 3D and hardware buffer. If i change to 2D or software mode it works correctly.

Thx

Here is the event:

<event>
<name>car2</name>
<parameter_nextid>1</parameter_nextid>
<layer_nextid>1</layer_nextid>
<layer>
<name>onload</name>
<height>100</height>
<envelope_nextid>0</envelope_nextid>
<mute>0</mute>
<soundlock>0</soundlock>
<envlock>0</envlock>
<controlparameter>rpm</controlparameter>
<sound>
<name>idle</name>
<x>0</x>
<width>0.454545</width>
<loopmode>0</loopmode>
<autopitchenabled>0</autopitchenabled>
<autopitchreference>0.128977</autopitchreference>
<finetune>0</finetune>
<startsynch>0</startsynch>
<stopsynch>0</stopsynch>
<volume>1</volume>
</sound>
<sound>
<name>onlow</name>
<x>0.340909</x>
<width>0.659091</width>
<loopmode>0</loopmode>
<autopitchenabled>0</autopitchenabled>
<autopitchreference>0.340909</autopitchreference>
<finetune>0</finetune>
<startsynch>0</startsynch>
<stopsynch>0</stopsynch>
<volume>1</volume>
</sound>
</layer>
<parameter>
<name>rpm</name>
<min>0</min>
<max>1</max>
<velocity>0</velocity>
<primary>1</primary>
<rangeunits>RPM</rangeunits>
<rangemin>0</rangemin>
<rangemax>8800</rangemax>
<rangespacing>1000</rangespacing>
</parameter>
<car_rpm>0</car_rpm>
<car_rpmsmooth>0.075</car_rpmsmooth>
<car_loadsmooth>0.05</car_loadsmooth>
<car_loadscale>6</car_loadscale>
<car_dialog>0</car_dialog>
<volume_db>0</volume_db>
<pitch>0</pitch>
<maxplaybacks>1</maxplaybacks>
<mode>x_3d</mode>
<rolloff>Logarithmic</rolloff>
<mindistance>1</mindistance>
<maxdistance>10000</maxdistance>
<headrelative>World_relative</headrelative>
<music>No</music>
<notes></notes>
<category>master</category>
</event>
</eventgroup>
<event>

  • You must to post comments
0
0

Hi!

I tested it on some more platform:
It works well with Creative Sound Blaster Audigy 4 , Creative Sound Blaster Live! Value and the integrated SoundMax device.

thx

  • You must to post comments
0
0

No. I’m saying that we now have 2 cards that doesn’t work: Live 24! and (a brand new) Sound Blaster Audigy SE. (and it works on Live 1024, Audigy (non SE!!) , SoundMax Integrated audio (and all other cards in the company :) ).

I’ve tested all cards in my machine (the results are above).
And the Live 24! and Audigy SE was tested in an other computer and it doesn’t work in that either.

And yes. it seems to be a card problem, but that doesn’t calm down my boss ๐Ÿ˜• .

thx

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.