0
0

Howdy @ all…

i am working with kdevelop. The whole project compiles fine (so the fmod header will be used, right?), but when the linker starts, i´ve got some “undefined reference to …” errors.

I´m searching for an answer about many hours, but with no success. Could someone tell me a little bit about linker flags? I am a newbie in this case.

I have to call a linker flag for the libfmod-3.74.so library. But what´s the shape of it? Will it look like -llibfmod-3.74.so (this one throws an “cannot find -llibfmod-3.74.so error”) ?

I would be glad about an answer! Even when it´s less a FMOD problem, than a general linker problem.

So far, many thx!

PS: I´ve copied the library to /usr/lib , and the header to /usr/include

  • You must to post comments
0
0

use -lfmod-3.74

  • You must to post comments
0
0

I did everything link mentioned here…
http://52.88.2.202/forum/viewtopic.php … ight=linux

but i still get a “cannot find -lfmod-3.74” error. :(

I copied the files, started ldconfig … and with the command
“ldconfig -p | grep fmod”
it lists the right library.

Output:

libfmod-3.74.1.so (libc6) => /usr/local/lib/libfmod-374.1.so

Hmm… in this list, there are some old lib´s, too. I made the mistake to install the “fmodex” verion, before the 3.74 version. But i already removed those files. Why are they still in the cache?

I don´t like those linker stuff… it always causes stress.

  • You must to post comments
0
0

-L/usr/local/lib -lfmod-374.1

In case /usr/local/lib isn’t in your $PATH.

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.