0
0

Hallo,

it is possible, that i have found a bug when using FModEx 4.02.00 with some WMA-Files.

I am developing an AudioPlayer based on FModEx 4.02.00. When I use the function setPosition() on some positions (only by wma-files) I get the error code FMOD_ERR_FORMAT (Unsupported file or audio format). This only happens with some positions and then only by the second call of setPosition().

For Example:
When the first time I call the function setPosition with the Parameter 10999 and the second time I call it with the Paramter 5000, then no error appears. But when I call the function setPosition again with the Parameter 10999, then I get the above mentionted error code.

I think its a bug, but i am not sure. If you want this wma file, I can upload it on you FTP-Server.

Thx, alci.

  • You must to post comments
0
0

Hi,

i uploaded the file on your ftp-server (filename: “problem_wma_file_ALCI.wma”).

The error occurs, when i call the function setPosition() with the parameter 173214 when using this file.

You have to call setPosition(173214) more than one time, than you should get the error i described in my first topic.

If it wont work or If you found out what the reason for the error is, than post it in this topic.

Alci

  • You must to post comments
0
0

Hi,

is the fix in the latest version (4.02.01) included? I tried it out but unfortunately the same error occurs. But it seems that the error occurs not so often as in the version before (4.02.00).

  • You must to post comments
0
0

Hi,

when will the fixed version released?

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.