0
0

I used fmod to give ability to play compressed files in one game. I used ordinary sample functions and streams with user callbacks. Everything is working just fine, but sometimes the game locks up for 4-6 seconds. Even mouse cursor isn’t moving, also Alt+Tab isn’t work, but in game music is playing.

Now, my ideas to catch this bug is exhausted.
Please, help me to find out it is fmod problem or not?

  • You must to post comments
0
0

OK, I found the problem. It wasn’t fmod issue so theme is closed.
Thanks.

  • You must to post comments
0
0

Try without fmod to see what happen ?

  • You must to post comments
0
0

In the begining game was using the mss32 sound lib. It worked ok. When I managed to disable mss32 and enable fmod, I began to experience lockups. I even made an experiment: I disable all functions, that start to playing sounds, so there was only init/de-init, volume and pan control and ‘IsPlaying’ functions. No in game sound but lockups still present!

  • You must to post comments
0
0

mmhhh it is difficult to see why with the given information but the first think wich came in mind is a threading issue as you are using your own user callbacks.

  • You must to post comments
0
0

Hm… It seems that this is a mixer issue because:
– I disable streaming but lockups still occur
– When I made ‘FSOUND_SetOutput(FSOUND_OUTPUT_NOSOUND)’ in initialization it gave no lockups
So I decide to change frequency from 44100 to 22050. First test didn’t give any lockups. I will test it more.

  • You must to post comments
0
0

WINMM and DSOUND also gave me lockups. In other hand I changed PlayEx functions to ordinary Play functions and than tested game about 1-1,5 hour with no lockups.

  • You must to post comments
0
0

Hmm…
I use ex version to start sounds in pause, then setup allocated channel (volume, panning) and than I unpause it. Nothing so special. DSP unit is always NULL.

  • You must to post comments
0
0

No, sample playing don’t makes the problem. This lockups so smart that freezes application system message queue so even ctrl+alt+del works only after the freeze pasts. I wonder what it may be? I am using Win2000. And Microsoft Visual C++ .NET Version 7.1.3088. Maybe I should change a compiler?

  • You must to post comments
0
0

OK, I’ll test fmod outside game. Maybe I break something when was adding fmod sound. Thanks for your patience.

Happy New Year!

  • You must to post comments
Showing 9 results
Your Answer

Please first to submit.