0
0

Hi,
i looked others subjects with the same problem but i can’t make it work…

I’m working with mingw and msys. C language.
I compile an application with fmod but i got errors like : undefined reference.

[code:3gk78aec]
gcc -W -Wall son.c
C:/DOCUME~1/Dr@ke/LOCALS~1/Temp/cc80baaa.o(.text+0x5df):son.c: undefined reference to FSOUND_GetVersion@0'
C:/DOCUME~1/Dr@ke/LOCALS~1/Temp/cc80baaa.o(.text+0x621):son.c: undefined reference to
FSOUND_Init@12′
C:/DOCUME~1/Dr@ke/LOCALS~1/Temp/cc80baaa.o(.text+0x646):son.c: undefined reference to FSOUND_GetError@0'
C:/DOCUME~1/Dr@ke/LOCALS~1/Temp/cc80baaa.o(.text+0x665):son.c: undefined reference to
FSOUND_Close@0′
[/code:3gk78aec]
After searching i compile with -lfmod-3.75 but he doesn’t know where to find it. I pasted it in some folders like “mingw\lib” but it still writes :

[code:3gk78aec]
gcc -W -Wall -lfmod-3.75 son.c
d:\Program files\msys\1.0\mingw\bin\..\lib\gcc-lib\mingw32\3.2.3\..\..\..\..\mingw32\bin\ld.exe: cannot find -lfmod-3.75
[/code:3gk78aec]

Please, help me :s

  • You must to post comments
0
0

it should be -lfmod if you have not rename the file.

  • You must to post comments
0
0

No it’s the same thing :s
Where do I have to copy the librairy ? Maybe I copied it in a wrong folder.
thx

  • You must to post comments
0
0

I am said to do that :

*make sure /usr/local/lib is listed in /etc/ld.so.conf
*copy the fmod lib into /usr/local/lib
*make an “fmod” directory in /usr/local/include
*copy the fmod headers into /usr/local/include/fmod

But with mingw and msys i have some problems to find the good folders.
I have a picture of my folders here
[img:1rl5chd0]http://drakeworld.free.fr/folder.jpg[/img:1rl5chd0]
Can you say me with that, how do i translate these lines in this situation.

Btw i don’t have any ldconfig..Neither a ls.so.conf :s

Plz help !

  • You must to post comments
0
0

[quote="thedrake":12y2nu5h]
[code:12y2nu5h]
gcc -W -Wall -lfmod-3.75 son.c
d:\Program files\msys\1.0\mingw\bin\..\lib\gcc-lib\mingw32\3.2.3\..\..\..\..\mingw32\bin\ld.exe: cannot find -lfmod-3.75
[/code:12y2nu5h]

Please, help me :s[/quote:12y2nu5h]

If you didn’t rename the file, why the compiler is searching for -lfmod-3.75 ? It must be -lfmod if you didn’t rename it. Change this in your makefile/linker settings.
Note that the file to copy is libfmod.a from “api\lib” folder to “mingw\lib”.

  • You must to post comments
0
0

ok..i thought i had to use the “linux” lib…
coding with mingw is not meant to “emule” linux coding ? xD
merci !

  • You must to post comments
0
0

You are right, mingw allow to fork a linux programming box but there are some differences between each OSes : they use their own lib format, elf .so binary file for linux and COFF lib for windows, there is not compatibility between them.
De rien 😉

  • You must to post comments
Showing 6 results
Your Answer

Please first to submit.