Alright, I’m at a loss on this one, so I’ll try posting here and see what comes up. I am trying to use Fmod Ex to connect to an internet stream (or radio station) at the following location(s):

These always error, so I tried it using the netstream example and got

“An Invalid Parameter was passed to this function” error.

After checking various other stations and even a static file hosted on my webserver, the netstream example came back with the same error.

Connecting to these sources (and others) using Fmod 3 resulted in no problems. So my conclusion was either Fmod Ex 4.02.07 has broken support, or…ya, I don’t know. I made no coding changes to netstream example, and passed the correct information (I even statically placed the addresses into the compiled code which resulted in the same problems)…
Is there something I’m missing which would cause such behaviour?

[code:10xcibkc]result = FMOD_System_CreateSound(system, "http://www.shawn64.com/shaltif/NG28731.mp3", FMOD_HARDWARE | FMOD_2D | FMOD_CREATESTREAM | FMOD_NONBLOCKING, 0, &sound);[/code:10xcibkc]

The above was the type of change I used for the netstream example. Maybe some testing on your end will yeild better results and a possible bug discovery/fix?

EDIT: Fixed on my part. Appearently the netstream example doesn’t like NONBLOCKING on.


  • You must to post comments
Showing 0 results
Your Answer

Please first to submit.