0
0

Hi all,

After I create the system and init system with enought channels then I call createSound with default value and valid audio file path. Everything is successfull but if I call sound.setMode(FMOD_LOOP_NORMAL) it returns OK but it won’t loop. And if I call channel.setMode(FMOD_LOOP_NORMAL) it still return OK but not loop.

Another case is that the only difference is I call createStream it works on both case.

The reason why I use createSound instead of createStream is that. If the audio file is on the Internet (starting with http://server/test.wp3) and it plays well. But before it stops it will playing some little bit at the beginning.

Any advice or suggestion? Thanks in advance.

Tom

  • You must to post comments
0
0

Hi Brett,

Thanks for the reply. However if I do not set the mode as hardware. I call system::createSound with FMOD_SOFTWARE it still not looping.

Then I keep it create with FMOD_SOFTWARE. Before I call set loop I call channel::setPause(true) then set the loop count t0 -1. At last I call channel::setPause(false). It play well but still not looping.

Is there any way to enable the loop after the audio is playing in win32 platform?

Your advice is very helpful. Thanks

Tom

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.