0
0

Hi,

I’ve tried to use FSOUND_FX_Enable and the FSOUND_FX_SetEcho like this:


var Index: Integer;
begin
Index := FSongs[Index].Channel;
FSOUND_Stream_SetPaused(Index, True)
FSOUND_FX_Enable(Index, 1.2);
// What does the single value affects?
FSOUND_SetFlanger(Index, ……);
FSOUND_SetPaused(Index, False);
// The sound hasn’t changed…
end;

What’s wrong in this example? I’ve paused the stream, then I enable the FX and set-up the effect(s) and finally a re-unpause the stream….

Thanks in advance…
email: www128@yahoo.com

  • You must to post comments
0
0

Your problem seems to be the way you’re trying to use the Enable function :

FSOUND_FX_Enable(Index, 1.2);

You need to use Bitwise OR’ing to get what you want. Like this (Single effect):

FSOUND_FX_Enable(Index, FSOUND_FX_FLANGER);

and for multiple effects :

FSOUND_FX_Enable(Index, FSOUND_FX_FLANGER OR FSOUND_FX_CHORUS);

Hope this help you. :smile:

  • You must to post comments
0
0

Hi,

If I use this procedure:


begin
FSOUND_FX_Enable(Index, FSOUND_FX_FLANGER OR FSOUND_FX_CHORUS);
end;

I receive a compiler error message, because the Cardinal & TSoundFXModes aren’t compatible… What’s wrong in the code? I use Delphi 6.0.

Thanks in advance…

  • You must to post comments
0
0

Arg I’am having the same problem can’t seem to enable effects. Realize its probably something small i’am doing wrong hopefully someone can point it out to me. Here is my VB snip

<pre>
mySong.ChannelHandle = FSOUND_Stream_PlayEx(FSOUND_FREE, mySong.songHandle, 0, 1)

    If mySong.ChannelHandle = -1 Then
        Call FSOUND_Stream_Stop(mySong.songHandle)
        Call FSOUND_Stream_Close(mySong.songHandle)
        Call FSOUND_Close

        GoTo PlayRSMFail
    Else
        mySong.EqHandle = FSOUND_FX_Enable(mySong.ChannelHandle, FSOUND_FX_PARAMEQ)
        Call FSOUND_SetPaused(mySong.ChannelHandle, 0)
    End If

</pre>

Though the song plays, mysong.EQHandle is always -1 (fail).

Thanks in advance.

<font size=-1>[ This Message was edited by: Cire on 2002-03-11 21:12 ]</font>

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.