Hello, as you might see I’m new to the forum here, and so as first action I would thank the FMOD developers for creating such an unbelievable great library. I already used FMOD before FMOD_Ex for some fun/learning applications some years ago (eg. my own little winamp ๐Ÿ˜‰ ).

Now, when FMOD_Ex came out I thought: “wow, a new name, does this mean new features..?” and so I downloaded it and now I love it more than before.

OK, enough of it :)

Also I’m working/programming in the game sector and therefore it was clear that I would try FMOD’s 3D features some day. Ehm, well, …… this day has come :)

Everything comes along quite nicely so far, but when I moved through my 3D world I recognised a funny thing about the 5.1 sound FMOD gives me.
All satellite speakers seem sounding quite right, but it seems FMOD does something wrong on the bass channel.

When my 3DListener’s looking direction is parallel to the ground the bass is very weak, now when I look upwards (into the sky for example) which means the 3DListener’s looking direction is quite perpendicular to the ground the bass is extremely loud (I think at it’s max).

or in less words:
if sound above or beyond player –> bass loud
if sound in front/back/left/right player –> bass weak

If I remember my early physics lessons right, the very low frequency sounds (which are in this case produced by the sub-woofer) can’t be located in a 3D room by a human ear. So it shouldn’t matter which direction the 3DListener is facing, the bass should always be the same volume and it should only depend on the distance between the Listener and the Sound.

So, what could cause this? Is my listener transformation code wrong? but I can’t believe that, because as said above, the position/direction shouldn’t matter.

Thanks for any help.

phu taking breath

I think this is the very longest FIRST POST I ever wrote on a forum ๐Ÿ˜‰ :)


  • You must to post comments

I recently used FMOD_HARDWARE where the problems currently occur.
Now I checked FMOD_SOFTWARE and there it’s gone, bass is as it should be.

I’ll check out the latest drivers, maybe your right and they will fix it.

Meanwhile thanks, it’s good to see that this is a vital forum, with replies within hours and not within days ๐Ÿ˜‰
keep it like that, I’ll check in from time to time to see if I could be a help for others too :)


  • You must to post comments

Ok drivers updated –> following situation.

Now if the sound is quite exactly beyond the listener all 6 channels become silent (completely?!)…..maybe that’s intended to be ??
and if the sound is quite exactly above the listener all 6 channels become loud (completely?!)…….that shouldn’t be intended ๐Ÿ˜‰

additionally the bass problem continues:
listener and sound at same height –> bass is quite silent
listener above sound –> bass is (completely?!) silent
listener beyond sound –> bass is (completely?!) loud

As said with FMOD_SOFTWARE it still works quite well (before and after the driver update).

My hardware is a Creative USB Sound Blaster Live! 24-bit External


  • You must to post comments

[quote="brett":1vsqgmfg]you probably have your speaker settings set up incorrectly in the control panel.[/quote:1vsqgmfg]

I think I have all settings right, everything else except fmod is working nice. Furthermore it’s very unlikey that wrong settings would cause such a wrongdoing.

…my situation in detail:
I use FMOD together with Ogre3D (which uses the default coordinate system –> right-handed). As I read in the FMOD Api reference, it uses the left-handed coordinate system.
So I thought myself: hey no problem, conversion is as simple as picking flowers :)
Simply negate the Z value of everything (positions/orientations) and everything should be fine.
But there is really some strangeness in FMOD (at least in the manual–>tutorials–>3d):
[quote="FMOD API":1vsqgmfg]…Take the right handed coordinate system, where +X points left and +Z points backwards, or comes out of the screen at you…[/quote:1vsqgmfg]

“where +X points left”……obviously wrong ?!
Point your thumb to the left, your index finger upwards and if you then are able to point your middle finger towards you…see a doctor ๐Ÿ˜‰
(But this could just be a error in the manual)

And when I convert the righ- into the left-handed coordinates (negating z values) I get the error from above, which quite sure can’t be caused of a wrong conversion?!…

thanks & greetings

  • You must to post comments

I have tried nearly everything what is possible for conversion, thrust me ๐Ÿ˜‰

Luckily I found there is a geometry example that comes with fmod too, which is by the way 3d :), and now I know that I’ve done nothing wrong :roll: 8)

Because there I get the same wrongdoing:
*) Listener above sound –> sound is completely silent (all 6 channels)
*) Listener beyond sound –> sound is completely loud (all 6 channels)

What could I do to solve this, is it a bug, driver problem (despite I have the latest installed), …!?

PS: sorry for nearly blaming fmod, but I fought this fight for several days and it really began to frustrate me :):)


  • You must to post comments

no idea? :(

  • You must to post comments


As said this behaviour doesn’t just appear in my own app, it also is present in the geometry demo that comes with FMOD, so you could check it yourself?!.

I’ts quite hard for me to get another soundcard to compare.


  • You must to post comments
Showing 6 results
Your Answer

Please first to submit.