0
0

I have a sound playing at -10,0,0 and the listener set up to 0,0,0 for the Position, while Up is 0,1,0 and Forward is 0,0,-1. I’ve inited the system to right handed, but changing the forward vector from -1 for the z to 1 for the z doesn’t flip the sound. The sound always plays in the left channel no matter what I do with the listener vectors for Forward and Up. It does respond appropriately when the position changes so it’ll move left to right when the listener moves left. I call system->Update every frame, and the sound IS 3D but the vectors seem to not change anything. In an older version of FMOD I remember it working, so I don’t know if it’s a new FMOD EX thing. Thanks for all your help so far by the way.

Edit: I’ve tried flipping the forward vector in a FMOD example app that came with the API, it’s the 3D one and the same problem exists. Reversing the forward vector doesn’t flip the channels or anything.

  • You must to post comments
0
0

are you using 4.04.11? There is a fix in 4.04.13 for a problem which made 3d sounds not pan.

  • You must to post comments
0
0

Ok I found the problem, FMOD_SOFTWARE sounds take the listener orientation vectors into consideration but FMOD_HARDWARE doesn’t. Is there a specific reason for this that the system::Update doesn’t handle? And would I have to load all 3D sounds into SOFTWARE mode to have the listener orientation effect sounds.

  • You must to post comments
0
0

FMOD_HARDWARE -does- take orientation into account. As a test I simply changed
FMOD_VECTOR forward = { 0.0f, 0.0f, 1.0f };
to
FMOD_VECTOR forward = { 0.0f, 0.0f, -1.0f };
in the ‘3d’ example in the fmod examples directory. It flipped left and right as expected. Does this happen for you as well? If so then it is something wrong with your sound card driver. What are you using, and are your windows control panel speaker settings set up correctly?

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.