0
0

Music on my Cel-700 is playing choppy and with flicks.
I tryed to enlarge buffer size. Sizes 10242, 10244, 10248 were too small, only 102416 remove chopping. But 1024*4 buffer size already cause unacceptable sound delay, so changing buffer size is not solution.

CPU usage in FMOD sample usercreatedsound.exe is about 2-3%, 96% is System Idle.

DxDiag excerpt:

[code:lelvcs3a]

System Information

Time of this report: 7/15/2006, 20:13:10
Machine name: DUPLO
Operating System: Windows 2000 Professional (5.0, Build 2195)
Language: Russian (Regional Setting: Russian)
System Manufacturer: n/a
System Model: n/a
BIOS: n/a
Processor: Intel Celeron, ~700MHz
Memory: 128MB RAM
Page File: 112MB used, 190MB available
Windows Dir: C:\WINNT
DirectX Version: DirectX 9.0 (4.09.0000.0900)
DX Setup Parameters: Not found
DxDiag Version: 5.03.0000.0900 32bit Unicode


DxDiag Notes

DirectX Files Tab: No problems found.
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Music Tab: No problems found.
Input Tab: No problems found.
Network Tab: No problems found.


DirectX Debug Levels

Direct3D: 0/4 (n/a)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (n/a)
DirectMusic: 0/5 (n/a)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)


Display Devices

    Card name: XPERT 98 RXL AGP 2X (English)
 Manufacturer: ATI

Display Memory: 8.0 MB
Current Mode: 1024 x 768 (32 bit) (100Hz)
Monitor: Monitor Max Res:
Driver Name: ati2drad.dll
Driver Version: 5.00.2195.4009 (English)
AGP Status: Enabled
DDraw Test Result: Not run


Sound Devices

        Description: CMPCI Playback ( Default Sound Playback: Yes

Default Voice Playback: Yes
Hardware ID:
Manufacturer ID: 1
Product ID: 56
Type: Driver Name:
Driver Version:
Driver Attributes:
WHQL Logo’d:
Date and Size:
Other Files:
Driver Provider:
HW Accel Level: Full
Cap Flags: 0x0
Min/Max Sample Rate: 0, 0
Static/Strm HW Mix Bufs: 0, 0
Static/Strm HW 3D Bufs: 0, 0
HW Memory: 0
Voice Management: No
EAX(tm) 2.0 Listen/Src: No, No
I3DL2(tm) Listen/Src: No, No
Sensaura(tm) ZoomFX(tm): No
Registry: OK
Sound Test Result: Not run


Sound Capture Devices

        Description: CMPCI Record (  Default Sound Capture: Yes

Default Voice Capture: Yes
Driver Name:
Driver Version:
Driver Attributes:
Date and Size:
Cap Flags: 0x0
Format Flags: 0x0
[/code:lelvcs3a]

full diagnostic report –
http://www.everfall.com/paste/id.php?vxngh2r4ay4z

  • You must to post comments
0
0

what buffersize were you changing? Did you use System::setDSPBufferSize?

  • You must to post comments
0
0

[quote="brett":3t50pqv7]what buffersize were you changing? Did you use System::setDSPBufferSize?[/quote:3t50pqv7]

Yes, I did.

[code:3t50pqv7]
static void SetFMODBufferSize(FMOD::System *fmod_system)
{
unsigned buffer_length;
int num_buffers;
FMOD_RESULT fmod_res = fmod_system->getDSPBufferSize(&buffer_length, &num_buffers);
assert(FMOD_OK == fmod_res);
if (FMOD_OK == fmod_res)
{
LOG_INFO("FMOD: buffer_length=%d, num_buffers=%d", buffer_length, num_buffers);
fmod_res = fmod_system->setDSPBufferSize(max(buffer_length, 1024U * 16), num_buffers);
assert(FMOD_OK == fmod_res);
}
}
[/code:3t50pqv7]

  • You must to post comments
0
0

Leave buffersize alone, and change numbuffers as the documentation suggests.

I would try 1024, 8 and if it persists then there is a bug with your sound card driver, or you are starving fmod’s mixer thread with your application somehow.

Just putting ‘CMPCI’ and ‘skipping’ into google comes up with plenty of matches, with an interesting one from xmms which said it is a driver problem, and to try different output modes.

You could also try changing output modes such as FMOD_OUTPUTTYPE_WINMM

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.