0
0

Hi,

Our sound designer has just started playing with the reverb environments. (I’ve just recently hooked it up to our engine.) He’s got two requests, though, and I’m not sure if the functionality is already there.

1.) The ability to adjust the ratio of reverb return vs dry sound. Ideally this would be a per-Channel setting. Maybe something in Channel::setReverbProperties()? Is this something I can do already? Or is it a feature request? :)

2.) Longer Reflections Delay and Reverb Delay. Dave is unsatisfied with the ranges on these delay values, especially for outdoor areas. He says "up to half a second would do well".

For reference, we’re using software reverb (set through System::setReverbProperties()), and we’re not using sound designer tool.

Thanks!

  • Guy
  • You must to post comments
0
0

[quote="Adiss":j6jgssan]Hi,

Our sound designer has just started playing with the reverb environments. (I’ve just recently hooked it up to our engine.) He’s got two requests, though, and I’m not sure if the functionality is already there.

1.) The ability to adjust the ratio of reverb return vs dry sound. Ideally this would be a per-Channel setting. Maybe something in Channel::setReverbProperties()? Is this something I can do already? Or is it a feature request? :)
[/quote:j6jgssan]
This is already implemented as the room effect in the Channel reverb properties structure

[quote:j6jgssan]
2.) Longer Reflections Delay and Reverb Delay. Dave is unsatisfied with the ranges on these delay values, especially for outdoor areas. He says "up to half a second would do well".
[/quote:j6jgssan]

FMOD conforms exactly to I3DL2 spec, so this is no different to all other I3DL2 reverbs and EAX.

If you want a longer echo effect, use echo.

  • You must to post comments
0
0

Thanks, I’ll hook up the Room effect, and tell Dave that he’s got to live with the parameter limits he’s got.

  • G
  • You must to post comments
0
0

The FMOD_REVERB_CHANNELPROPERTIES::Room (and RoomHF) doesn’t seem to be working for me.

Here’s the code I’m using:
[code:b5i639st]FMOD_REVERB_CHANNELPROPERTIES tChannelProps;
res = pSound->pChannel->getReverbProperties(&tChannelProps);
if(res == FMOD_OK)
{
tChannelProps.Room = pSound->pSoundGroup->nReverbSend;
tChannelProps.RoomHF = pSound->pSoundGroup->nReverbSendHF;
tChannelProps.Direct = pSound->pSoundGroup->nDirectPathLevel;
tChannelProps.DirectHF = pSound->pSoundGroup->nDirectPathLevelHF;
tChannelProps.Flags = FMOD_REVERB_CHANNELFLAGS_ENVIRONMENT0;
pSound->pChannel->setReverbProperties(&tChannelProps);
}[/code:b5i639st]

I’m in software mode; I go into a reverb environment and play the sound with values 0 for Room, RoomHF, Direct, and DirectHF (ie all defaults) and I get full reverb send. I then set all four of those values (even all the different combinations) to -10000 and it makes absolutely no difference. I also tried it without fiddling with the Flags property, leaving it as default.

Is there something I’m doing wrong or that I’m missing?

Thanks,

  • Guy
  • You must to post comments
0
0

Whoops!

Never mind. Turns out I was using the wrong version of FMOD. 😳

My apologies.

  • Guy
  • You must to post comments
0
0

only Room effect will work by the way, none of the other parameters are used. (we’re actually probably deleting that structure soon)

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.