0
0

All my FMOD::Sound’s are created as head relative 3D samples, using FMOD_SOFTWARE | FMOD_3D | FMOD_3D_LINEARROLLOFF | FMOD_3D_HEADRELATIVE.

(I can’t guarantee that it will always be Software, so I need to be able to fake 2D in 3D for future dev directions)

To fake 2D, I’m using FMOD_3D_HEADRELATIVE as the channel mode, setting my position and velocity to zero, and set3DSpread to 90. There is no stereo spread in my headphones, though. If I switch back to a true 2D sound, I definitely get a stereo sound field.

Any ideas what I could be doing wrong?

BTW, this is in 4.04.24.

Thanks,
Sean

  • You must to post comments
0
0

Figured it out. I had to set my position to <0,0,1>!

Sean

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.