0
0

When using the designer tool you can specify source files for the tool to pull your audio from. When the designer tool "Builds" a project it builds sound bank files that contain all of the source audio.

If I delete the source audio off my drive after I have created my sound banks and then open up my designer project file the events will not play anymore (I get the "cannot find source" error).

I dont understand this. Why do I need the source files once a sound bank has been created when they are not needed for the code to run the event files?

Also, maybe I just missed a setting so if this is possible please let me know!

Thanks,
Kyle

  • You must to post comments
0
0

FMOD Designer uses the source files for playback. How do you think you can hear your newly created events before you’ve done a build?

  • You must to post comments
0
0

I’m aware of that, but why? After the project has been built I see no reason to need a copy of those source files.

I have to distribute a copy of every source file to all of the people that want to work on my project at the same time when they will already have the sound bank files. Cant there be some kind of mode that reads from the sound bank files instead? Or, once you build, it always searches and uses the sound banks first before pulling the source files.

  • You must to post comments
0
0

[quote:24ye7md3]After the project has been built I see no reason to need a copy of those source files. [/quote:24ye7md3]

You’ll need them if you want to rebuild the banks which you’ll have to do if you add or remove any events (potentially), edit any waveforms, change any bank settings (compression, compression quality) etc. Also, many banks with platform-specific compression can’t be played back on PC e.g. XMA, VAG.

I see your point but I’m loath to add complexity in this way for questionable benefits when there are much more pressing issues at hand.

May happen next year.

Cheers,

  • You must to post comments
0
0

haha, I see now :)

Thanks!

Kyle

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.