0
0

I have been trying to solve a crash that appeared in my code some day ago and at first I thought it was something I was doing wrong that casued the crash but when I emulated the scenario in eventplayer that app crashed as well so I’m assuming it’s either data being corrupt or a bug in your code. Actually, if the data is corrupt then it’s a bug in your code as well.

What happens basically, translated to eventplayer, is that I load this magic project and trigger a certain combination of events and while they are playing I unload the project. CRASH!!! In my code where I know more in detail what is going on I load the project and the eventgroup, trigger the magic combination of events and while playing I call freeEventData and KABOOM!!! Looking at the logs they end with different output for every combination of events that cause a crash so I can’t see anything obvious that causes the crash.

By the way, I’m running 4.04.27 dev (Win32) but it appeared in 4.04.23 as well.

Any idea what’s causing this mess?

  • You must to post comments
0
0

Can you upload the project to http://ftp.fmod.org u:upload p:upload so I can check it out?

Cheers,

  • You must to post comments
0
0

uploaded

  • You must to post comments
0
0

Thanks I’ll check that out.

  • You must to post comments
0
0

Found anything yet?

  • You must to post comments
0
0

Apologies Ljudas, we’re extremely busy at the moment but I’ll try to get onto this as soon as physically possible.

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.