0
0

Hi all –

I’m a little confused by the FMOD_SYNCPOINT data type. What does it hold? I’m currently implementing an FMOD_CHANNEL_CALLBCKTYPE_SYNCPOINT function, and I’m a little confused as to why the interface changed from FMOD 3.75’s callback which just gave the name back.

I’m pretty new to audio programming, so sorry for the newbie-ish question – I’m just assuming my own ignorance.

Thanks!

  • You must to post comments
0
0

It doesnt really ‘hold’ anything for you to look at, it just is used as a handle that you pass to sound functions.

  • You must to post comments
0
0

Hmm, ok, that makes sense.

I’m still having trouble recieving a callback signal, though…

It’s strange, the End callback is working fine, but the sync ones aren’t getting hit.

[code:1k74wzyr]
//This works
chn->setCallback(FMOD_CHANNEL_CALLBACKTYPE_END, SoundEndCallback, 0);

//This doesn’t
chn->setCallback(FMOD_CHANNEL_CALLBACKTYPE_SYNCPOINT, SoundSyncCallback, (int)handle.GetValue());
[/code:1k74wzyr]

For some reason, the Stream ending callback is getting generated, but the synchpoint callback isn’t. I’ve verified that my test stream has synch points in it (the same file generates callbacks in FMOD 3.75) It builds fine, I don’t even get warning messages.
Do I need to use software mixing or something in order to get the sync callbacks?
Thanks for your help!

  • You must to post comments
0
0

Can you try the fmod file that comes with syncpoints, jbtennis.wav.

You can also try using Sound::addSyncPoint. It may be that your file is not really containing sync points.

  • You must to post comments
0
0

Hey Brett –

Thanks, jbtennis.wav works. I’ve done some digging with my file, and it seems to be an issue with my Soundforge Export settings. (I’m using Soundforge 7.0) Previously, I was embedding the tags, then exporting as Mp3. In FMOD 3.75, that works (it hits the syncpoints). In FMOD Ex, right now it doesn’t seem to. When I reload my Mp3 files into soundforge, I still see the tags, though. So I re-exported as a straight .wav and the synchpoints were hit.

So, this is better than it was before, but it would be really nice if I could keep the compression on my file (I’m tagging up pretty long music files). Do you have any advice for tagging Mp3’s?

Thanks for all your help!

  • You must to post comments
0
0

mp3 files dont store sync points.

You have to save as wav, and use mp3 encoding as the wav coded to do what you want.

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.