0
0

Hi,

in the 3d example, the doppler effect works fine, but I can’t get it working in my own application. I’m using exactly the same initialization and sound creation flags as the demo does. 3D settings are default (all 1.0). The sound being played comes from a mono-channel WAV file.

The rolloff effect works, also when I put the sound on the left side of the listener, I hear it like coming from the left, but the doppler effect just won’t be there.

Setting the velocity of a channel or the listener doesn’t change anything for me. I have even tried setting the velocity to a high random value each update tick, hoping to hear some jitter in the sound, but it keeps playing like normal. The return value of set3DAttributes is FMOD_OK, and when I retrieve the velocity with get3DAttributes, it is the correct vector.

I’m also calling System::update each frame.
Setting the doppler scale value doesn’t help either.

The only difference between the 3d example and my program is that my program makes the fmod calls from a DLL (the engine is in a DLL). Could that be the reason?

I’m getting quite desperate and would appreciate any help.

Thanks in advance,

David

  • You must to post comments
0
0

No need to reply any more.
I switched to the new FMOD version, and now it works.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.