0
0

One tester who’s on a 500 MHz/128 MB/Windows 98 setup is experiencing buffer underruns, and no amount of buffersize raising seems to help at all. (I went all the way up to 10 seconds)

I am streaming a small MOD file of about 80 KB.

Is there anything else I can do to make things work for him?

  • You must to post comments
0
0

Did you check the documentation on this?

If you are playing a mod, there is decode buffersize for a stream. setStreamBufferSize is only for file access. This will not affect mods as there is no file access.

setDSPBufferSize is the other one, which one did you use?

  • You must to post comments
0
0

Oddly enough, I didn’t need to change the buffersize after all. Setting the flag to software rather than hardware fixed the problem. Do you know why that would be?

  • You must to post comments
0
0

Ok so you didnt say you were using FMOD_HARDWARE. You have most likely just encountered

[quote:2aj7vzax]
[list:2aj7vzax]
[:2aj7vzax]Bad soundcard drivers – This may be solved by upgrading your soundcard drivers. (Note it is recommended you get the latest drivers anyway) [/:m:2aj7vzax][/list:u:2aj7vzax]
[/quote:2aj7vzax]

There is a whole section on this in the windows platform issues in the documentation.

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.