0
0

I have noticed that when calling FSOUND_Stream_Play() that there is a small delay. This delay is enough to cause a noticeable pause in our game when we play a previously opened stream in response to some action the player has done. What would be the reason for this delay and is there any way around it?

  • You must to post comments
0
0

Oh, Brett. I just noticed that my little description has changed to something more appropriate. Except it’s spelt ‘deity’. A diety would be a deity on a diet I guess. :smile:

  • You must to post comments
0
0

I don’t know if I’m suffering from the very same problem, but I’m also suffering from synching problems at the start of streams. I open a stream using Open and then i start the stream. The timer (gotten getTime) is 0 for some time (the song is being played though) and this might just be a precision issue, but when I later do a setTime on the stream getTime does not return the same time as I set it to using setTime.

Is this some kind of soundBufferSize-thing? The time return from getTime is smaller than the time set by setTime, about 250ms. I’m running SBLive 1024 under win2k and I just let the program take the standard driver (that is, I did not try switching fmod-driver). Any ideas?

Also the help (fmod.chm) says that getTime for stream returns 0 when there is something wrong going on but if I start the stream and then take getTime it returns 0 (probably indicating that it is not playing the stream yet). This is ok. Hm.

Oh well, what I want is probably some ideas on problems with getTime and how to make workarounds for them :)

  • You must to post comments
0
0

An extra note. We are using DirectSound on Win2K for development. Would this affect the default setting of the buffer size? I noticed that the documentation for FSOUND_SetBufferSize() states that NT gets a default buffer size of 200. Is Win2K included in FMOD’s definition of NT?

  • You must to post comments
0
0

Has this been resolved? I am having the same problem. I am running win2k on a 1.7G P4, and I get a pause as well, enough to interrupt our game noticeably.

  • You must to post comments
0
0

Excellent, thanks!

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.