0
0

Hi,
I’m trying to get the doppler effect to work, but there seems to be none (or I am absolutely ear-dumb). I try to hear it in both the 3d and the geometry examples, changed the used sounds (to sine and saw waves) and scaled the doppler effect up to 5.0 via System::set3DSettings(). I even scaled the velocity in the update functions by 100 – nothing happened. Is there some global setting that has to be used? Some flag when loading the sound or something like that (the documentation lets me think that this is something that should work by simply using the FMOD_3D flag when loading the sound).

Greetings,
Konstantin

  • You must to post comments
0
0

Hi,
It looks like the culprit is the new Channel::set3DDopplerLevel.
The default was setting it to 0, instead of 1 like it should be, so if you call set3DDopplerLevel(1) you should be ok.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.