0
0

I’m having a difficult time getting hardware reverb to work. I’ve coded up a minimal example to demonstrate.

[code:11niox6h]#include "fmod.hpp"

include <stdio.h>

include <stdlib.h>

include <windows.h>

int main () {

FMOD::System * system;
FMOD::Sound * sound;
FMOD::Channel * channel;

FMOD::System_Create(&amp;system);

system-&gt;init(100, FMOD_INIT_NORMAL, 0);

system-&gt;createSound(&quot;intro00.wav&quot;, FMOD_3D | FMOD_HARDWARE, 0, &amp;sound);

const FMOD_REVERB_PROPERTIES reverbProp = FMOD_PRESET_CAVE;
system-&gt;setReverbProperties(&amp;reverbProp);

system-&gt;playSound(FMOD_CHANNEL_FREE, sound, false, &amp;channel);

bool isPlaying = true;
while (isPlaying) {
    channel-&gt;isPlaying(&amp;isPlaying);
    system-&gt;update();
    Sleep(25);
}
Sleep(1000);
system-&gt;close();

return 0;

}[/code:11niox6h]

If I create the sound as a software voice, I can hear the reverb just fine. I’ve double-checked that EAX on this machine is enabled. The current audio engine (using DirectSound) demonstrates this.

Am I missing something obvious here… a required flag or function call?

  • You must to post comments
0
0

Thanks just fixed this for today’s release (or maybe tommorow)

  • You must to post comments
0
0

Fantastic, thanks Brett. Appreciate the quick fix!

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.