0
0

Hello, When I use FMOD_UNICODE and i try to load an url, i receive FMOD_ERR_FILE_NOTFOUND. If i try using an existing file it works.

Also if i do not use FMOD_UNICODE, the url is loading fine.

This is the code that returns FMOD_ERR_FILE_NOTFOUND.
The url is a real one, of an online radio.

result = system->createStream((char*)L"http://193.108.24.21:8000/fresh.ogg", FMOD_DEFAULT | FMOD_UNICODE , 0, &_soundHandle);

Am I doing something wrong?

  • You must to post comments
0
0

URLs are limited to a specific subset of the US-ASCII character set. Passing in a Unicode string when a URL is expected makes no sense. So, FMOD appears to be doing the correct thing by rejecting the string, although a more explicit error message would be helpful (like invalid parameters).

  • You must to post comments
0
0

[quote="JamesB":g798umcf]URLs are limited to a specific subset of the US-ASCII character set.[/quote:g798umcf]

Well.. they’re slowly introducing unicode hostnames.. With all the confusion that can make. So that means that URLs will probably have to be unicode as well, at least the address part.

  • You must to post comments
0
0

Well it makes no sence to me to reject an url because it is unicode.

The point is that in my app i use unicode strings as i want to be able to load all posible filenames, and ofcourse i do not make a difference if it is a filename or url(same as in fmod). But then i came into this problem and now i have to check if the filename begins with http or https(which as i understood fmod does too) and if so cast it to non-unicode string and pass it to fmod.

Its no big deal, but i still dont thing what fmod does is the correct behavior. And ofcourse you can put that as a remark in the documentation if you like.

Thanks.

  • You must to post comments
0
0

we can probably just do a wcstombs inside the net open function internally if the unicode flag is set. i’ll look into it for the next version.

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.