0
0

[code:14ti8ky2]

5/04/07 4.07.11 – Dev release update

  • FSBank – add support for multichannel mp3 encoding from multichannel wave files.
  • Add support for multichannel mp3 encoded FSB playback.

  • Event API – Fixed event categories not inheriting mute flag from parent category
    during add.

  • Event API – Fixed newly created events not inheriting mute flag from category.
  • Event API – Fixed problem with streamed wavebanks that contain 2D and 3D subsounds.
  • Fixed 24-bit AIFF problems between fsb storage and readback.
  • Wii – Fixed hang when releasing stream while disk is ejected.
  • PS3 – Fixed output buzzing.
  • Fixed bad Pro Logic encode caused by using -3dB midpoint pan gain.
  • Fixed system flag FMOD_INIT_3D_RIGHTHANDED getting reset.
  • PS3 – Fixed rare popping when reverb is enabled.
  • Wii/GC – Fixed hardware lowpass being disabled whenever a channel is paused and
    then unpaused.
  • Wii/GC – Fixed hardware channel reverb and lowpass properties not being preserved
    when channel swaps from virtual to real.
  • Wii – Fixed FMOD_Channel_GetControllerSpeaker not returning the correct value.
  • Wii – Fixed normal speaker sounds sometimes playing out of the controller speaker
    when channel swaps from virtual to real.
  • Wii/GC – Fixed problems when streaming mixed mono/stereo fsbs.

  • PS3 – Release is now built using Sony SDK 1.54.001
    [/code:14ti8ky2]

This thread is for discussion / bugreports for the current release.
Download the current release from the front page at http://www.fmod.org

  • You must to post comments
0
0

There are some problems with the use of System->createCodec(FMOD_CODEC_DESCRIPTION) with 4.07.11.

Creating the codec is fine, but calling createStream crash somewhere in fmodex.dll.

I’ve written a little test file (c++) with the raw_codec example, it can be found here [url:3ls5n9wu]http://jerome.jouvie.free.fr/downloads/codecrawtest.cpp[/url:3ls5n9wu]

  • You must to post comments
0
0

[quote="jouvieje":2bdkewvl]There are some problems with the use of System->createCodec(FMOD_CODEC_DESCRIPTION) with 4.07.11.

Creating the codec is fine, but calling createStream crash somewhere in fmodex.dll.

I’ve written a little test file (c++) with the raw_codec example, it can be found here [url:2bdkewvl]http://jerome.jouvie.free.fr/downloads/codecrawtest.cpp[/url:2bdkewvl][/quote:2bdkewvl]

Thanks for that – i fixed it for our next release, looks like the new getwaveformat function pointer wasnt been copied across properly.

  • You must to post comments
0
0

@brett : Thanks

I’ve got also some troubles with channel end callback. Can you take a look to the following topic ?
[url:3hjjltmf]http://www.fmod.org/forum/viewtopic.php?t=8068[/url:3hjjltmf]

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.