0
0

In regular stereo mode on PC I hear reverbs just fine with my sounds, but as soon as I switch my computer over to using 5.1 mode (I have a 5.1 speaker setup…) the reverb either goes away or becomes too quiet to be able to distinguish it from playing a sound without it (if i crank my speakers I can barely hear the remnants of it, but not too much).

The question is, is there some kind of special care needed to be taken with reverb effects when in 5.1 speaker mode? If not, is there a way I can debug to see what is wrong? None of my fmod calls in either stereo or 5.1 mode fail or return error messages so the only difference is that it just doesn’t work in 5.1 mode.

Thanks,
Kyle

  • You must to post comments
0
0

No there is nothing special to do.
I assume you’re switching your windows speaker settings to the same setting you are setting in fmod as well? You can’t have them different, thats why the recommended method is to use getDriverCaps and pass the controlpanelspeakermode to System::setSpeakerMode.

Also I assume you have tested this on a recent version of fmod? Just in case you are on a very old version or something.

  • You must to post comments
0
0

Sorry I took so long to get back to you, I thought I put this topic on watch, but I guess not :(

I do use getDriverCaps and I pass that to setSpeakerMode.

I’m on the latest version of FMOD. FWIW, I have artists that have the same sound card and speaker setup as I do and they hear things just fine. This might just be some kind of driver issue with my setup. :(

Thanks for the information though!
Kyle

  • You must to post comments
0
0

To make sure it sounds the same on every machine use FMOD_SOFTWARE otherwise you may be running into driver issues.

If it still sounds different, then it can only be your hardware setup.

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.