0
0

I’m using Visual C++ 2005 Express Edition and am getting the following errors:

cFMODSound.obj : error LNK2001: unresolved external symbol "public: enum FMOD_RESULT __thiscall FMOD::Sound::release(void)" (?release@Sound@FMOD@@QAE?AW4FMOD_RESULT@@XZ)
cFMODSound.obj : error LNK2001: unresolved external symbol "public: enum FMOD_RESULT __thiscall FMOD::System::playSound(enum FMOD_CHANNELINDEX,class FMOD::Sound *,bool,class FMOD::Channel * *)" (?playSound@System@FMOD@@QAE?AW4FMOD_RESULT@@W4FMOD_CHANNELINDEX@@PAVSound@2@_NPAPAVChannel@2@@Z)
cFMODSound.obj : error LNK2001: unresolved external symbol "public: enum FMOD_RESULT __thiscall FMOD::System::createSound(char const *,unsigned int,struct FMOD_CREATESOUNDEXINFO *,class FMOD::Sound * *)" (?createSound@System@FMOD@@QAE?AW4FMOD_RESULT@@PBDIPAUFMOD_CREATESOUNDEXINFO@@PAPAVSound@2@@Z)
cFMODSound.obj : error LNK2001: unresolved external symbol "public: enum FMOD_RESULT __thiscall FMOD::System::getVersion(unsigned int *)" (?getVersion@System@FMOD@@QAE?AW4FMOD_RESULT@@PAI@Z)
cFMODSound.obj : error LNK2001: unresolved external symbol "public: enum FMOD_RESULT __thiscall FMOD::System::update(void)" (?update@System@FMOD@@QAE?AW4FMOD_RESULT@@XZ)
cFMODSound.obj : error LNK2001: unresolved external symbol "public: enum FMOD_RESULT __thiscall FMOD::System::init(int,unsigned int,void *)" (?init@System@FMOD@@QAE?AW4FMOD_RESULT@@HIPAX@Z)
cFMODSound.obj : error LNK2001: unresolved external symbol _FMOD_System_Create

I have:

include "FMOD/inc/fmod.hpp"

include "FMOD/inc/fmod_errors.h"

in the top of the file and

FMOD/lib/fmodex_vc.lib
in the project properties -> linker -> input -> additional dependencies

Any help would be muchly appreciated.

  • You must to post comments
0
0

Adding Win32 to my preprocessor definitions solved my problem immediately, thank you.

  • You must to post comments
0
0

I started again from scratch and ran into the same problem but by comparing it to the examples I found i had ‘enable incremental linking’ set to ‘yes (/INCREMENTAL)’ and after changing it to ‘no (/INCREMENTAL:NO)’ it started working.

P.S. MELBOURNE FTW!

  • You must to post comments
0
0

ok thanks for the update.

  • You must to post comments
0
0

I’m having the same problem, but this didn’t work for me.

All I had to do was add ";WIN32" to the pre-processor definitions.

Hope this helps the next guy

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.