0
0

Hello

I would like to have a looped sound event that uses a sound definition that has a number of wave forms, with randomized pitch, volume and spawn time set to it.

Although it appears I can do this in the FMOD Designer, when I audition, none of these settings apply until the loop is retriggered (with the exception of the Spawn Time that does no appear to make any difference at all).

I hope someone can help! :)

  • You must to post comments
0
0

You can do this with one sound as you originally requested :

Place your one sound in a layer.
Right click on it and select "Sound instance properties…".
Set "Start mode" to "Wait for previous" and set "Loop mode" to "Oneshot".
Goto the sound definition tab and find your sound definition.
Set "Spawn time" to 1, 1.
Set "Maximum spawned sounds" to 1.
Go back to event editor tab and play your event.
It will choose a different sound definition entry and randomisations for each loop.

Cheers,

  • You must to post comments
0
0

Superb – thanks Andrew, that does the trick nicely. I had confusion over looped sound instances and looped events when constructing this in the event editor.
Anyway, all seems pretty logical now I’ve got my head around it.

  • You must to post comments
0
0

where are you auditioning it? Are you auditioning the event or sound definition or do you mean network audition?

  • You must to post comments
0
0

Hello

Coming back to this work, I have discovered that the random settings (spawn time, pitch, volume) does not work when the related parameter is not the primary one.

Is there any way around this?

thanks
Rebecca

  • You must to post comments
0
0

Hi Brett

I tried auditioning from the event and the sound definition in the FMOD Designer.

thanks
Rebecca

  • You must to post comments
0
0

[quote="andrew":4eegj9xi]You can do this with one sound as you originally requested :

Place your one sound in a layer.
Right click on it and select "Sound instance properties…".
Set "Start mode" to "Wait for previous" and set "Loop mode" to "Oneshot".
Goto the sound definition tab and find your sound definition.
Set "Spawn time" to 1, 1.
Set "Maximum spawned sounds" to 1.
Go back to event editor tab and play your event.
It will choose a different sound definition entry and randomisations for each loop.

Cheers,[/quote:4eegj9xi]

Should doing this allow for the seamless stitching of loops? I’m trying this with some music loops and I’m getting brief pauses before the next loop is spawned. My intent is to create a long song out of much smaller parts, and possibly apply effects to the song like an LP filter (that’s why I’m trying this in the Event side of things, as opposed to the Interactive Music side). I’m using Designer version 4.28.05.

Thanks,
Sean

  • You must to post comments
0
0

If you want it to play a different sound definition entry every loop then no, you can’t do it using looped sounds. You need to retrigger the sound for it to choose a different sound definition entry etc. You might get the effect you’re after using oneshot sounds with spawntime?

  • You must to post comments
0
0

Set "Maximum spawned sounds" to 2 and it will be seamless.

  • You must to post comments
0
0

Hi

Unfortunately this is not a one shot that is triggered in the world but a looped ambience sound, so therefore your suggestion for an alternative is not really suitable.

I could try to get some coding support to get this functionality, but i doubt it will be well received as we’ve decided to spend money on this Sound Designers DIY Tool ๐Ÿ˜‰

I would highly recommend adding this feature to your wish list, as this is a commonly used sound design technique to make looped sounds not appear as ‘looped’ sounding, as it breaks up the repepitiveness and adds variation.

kind regards,
Rebecca

  • You must to post comments
0
0

Thanks, Andrew. That solved that. I didn’t realize that it needed that 2nd sound ready to go before the 1st one ended, but it makes sense since I assume it’s needing to get it buffered-up.

Sean

  • You must to post comments
0
0

he said use one shot sound definitions with spawn timers – check the sound definition properties.

  • You must to post comments
0
0

Yeah it’s not the most obvious feature ๐Ÿ˜• Glad to hear it’s working for you though.

  • You must to post comments
0
0

I already tried the spawn timers. Again, it only worked with one shots after each spawn, but not on looped events that contains a number of one shot samples.

  • You must to post comments
0
0

Try an event with a parameter that has a velocity.
Then have 2 sound definitions in that event side by side.
Next set them both to ‘wait for previous’ and ‘loop and play to end’ in the sound definition properties.

Your actual sound definitions can be as random as they want, and they will join up automatically, and you can control the timing of the switch over using event parameter velocity.

  • You must to post comments
0
0

Ok – thanks Brett. I’m about to head off home but i’ll give this a go on Monday and let you know how I get on.

Have a good weekend!

  • You must to post comments
0
0

Hi Brett

I’ve tried your suggestion. This does make the random pitch and volume settings work, but not the spawn time, regardless of the velocity parameter settings.

thanks
Becca

  • You must to post comments
Showing 16 results
Your Answer

Please first to submit.