0
0

Regarding http://52.88.2.202/forum/viewtopic.php?p=33561:

I tried the "caps & FMOD_CAPS_HARDWARE_EMULATED" check. My SigmaTel Audio driver is failing this test, but the Hardware Acceleration slider is set to full.

The test computer is a modern Dell laptop (Latitude D820)

Does this indicate a faulty hardware setup, or is getDriverCaps returning bad data?

  • You must to post comments
0
0

Actually I just realized our test is setting that flag if there are no hardware channels as well as directx reporting that is is emulated. I assume you mean your problem is ‘sigmatel is reporting emulated even if acceleration is set to full?’

I’ll test this some more and set the flag only if the directx caps is saying it is emulated.

  • You must to post comments
0
0

[quote="brett":20xd9ku8]I assume you mean your problem is ‘sigmatel is reporting emulated even if acceleration is set to full?'[/quote:20xd9ku8]

Correct. getDriverCaps is reporting FMOD_CAPS_HARDWARE_EMULATED even though acceleration is set to full.

-Erik

  • You must to post comments
0
0

Ok i’ve verified this.

What it used to mean is correct – it is emulated by directsound software mixing – but i’ll change it to only report when the slider is 0 because directx has a check for that.

We’ll update the release to 4.06.31 and 4.08.03 in the next few hours to address this.

  • You must to post comments
0
0

Thanks for the quick turnaround!

-Erik

  • You must to post comments
0
0

ok the new version is out now.

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.