0
0

Hi,

I’m loading the codec_midi.dll using the LoadPlugin function before I call system_init. I’m not letting fmod find the plugins it requires I am, instead, loading the ones I want using the LoadPlugin function. Anyway, It returns OK meaning it loaded correctly when I load the codec. Now, when I try to play a midi file in my app it returns this: "ERR_FORMAT – Unsupported file or audio format". I’ve tried this with different midi files and it returns the same result. I also have tried playing them in windows media player and they play fine with it.

Other files like mp3, ogg, xm do play without error.

I am also using the FMOD.MODE.SOFTWARE and FMOD.MODE._2D flags to play the files. FMOD.MODE.HARDWARE returns the same error for the midi files.

I just updated to the Version 4.10.00 today as well in hopes it would fix this. Obviously didn’t work. lol. I believe this is a fmod bug as I’ve done everything I can think of to try to fix this.

Plugins I have loaded:
codec_mpeg.dll
codec_midi.dll
codec_it.dll
codec_mod.dll
codec_s3m.dll
codec_xm.dll
codec_cdda.dll
codec_oggvorbis.dll
codec_wav.dll
output_dsound.dll

Thanks for reading.

  • You must to post comments
0
0

try loading the dls plugin as well, this is probably why you get that message it doesnt know how to load .dls files to play back the midi.

  • You must to post comments
0
0

Yes, this fixed it. doh. Thanks brett.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.