0
0

When I don’t call fmod.dll dynamically, my program works fine.

But when I do my own loading, and the first sound starts playing, after a few seconds, the program gets a page fault, even without executing any of the instructions in the main thread.

SSTOGO caused an invalid page fault in
module <unknown> at 0000:00f2a3c1.
Registers:
EAX=817515c4 CS=014f EIP=00f2a3c1 EFLGS=00010206
EBX=007af460 SS=0157 ESP=006b0071 EBP=006b0090
ECX=006b0118 DS=0157 ESI=006b015c FS=19c7
EDX=bff7678c ES=0157 EDI=006b0140 GS=0000
Bytes at CS:EIP:
3a 5c 50 72 6f 67 72 61 6d 20 46 69 6c 65 73 5c
Stack dump:
40bff767 60006b01 5c007af4 18006b01 4c006b01 8c006b02 60bff767 28007af4 f3006b01 40bff858 60006b01 5c007af4 18006b01 c0006b01 0800f2a3 24006b03

My copy of QuickView doesn’t show the addresses of the exported functions, so I can’t tell where in the DLL it’s dying. The sound continues to play despite the page fault. I’m using STREAM input.

Any clues?

Has anyone else successfully used STREAM input when doing his/her own DLL load?

Thanks,
Elly

  • You must to post comments
0
0

Could you show us some of the code you use to load the DLL? I’d say the problem will be in there.

  • You must to post comments
0
0

I took a look over your code, but could not see anything majorly wrong. Your question did prompt me to finally get the dynamic linking part of the Delphi FMOD unit in place, so after two hours work it was done. Tested with the Delphi testbed application, it works fine. Unfortunately I left it at home, so you will have to wait until tomorrow to get it. 😀

Read my reply [url=http://www.fmod.org/forum/viewtopic.php?p=3460#3460:1zyulay8]here[/url:1zyulay8] in the General forum for the more info.

  • You must to post comments
0
0

Indeed, I started over and was successful.

But I’m looking forward to the “official” version anyway.

Thanks,
Elly

  • You must to post comments
0
0

Here is a link to the new [url=http://turbo.gamedev.net/fmoddelphi350dyn.zip:1tjbktih]Delphi units[/url:1tjbktih] for FMOD that allow static or dynamic linking. Dynamic linking is disabled by default. To enable dynamic linking, define FMOD_DYNAMIC_LOAD at the top of fmod.pas. Kylix support for dynamic linking should be complete if someone with Kylix can check the three lines that follow the FIXME comments.

fmoderrors.pas is included because it has two small fixes to help make it Kylix compatible (fixed case of unit name).

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.