0
0

Hi, I’m new to Fmod
what I’m trying to do is use fmod in a simple opengl game I’ve made to stream background music, but all i can manage to do is run it in a console window, as soon as i add Fmod to the game, i get linking errors. I was wondering if there is an easy fix, or if someone could provide code for a simple opengl window with a square in the middle, streaming music through fmod.
Hopefully you can help me, or at least point me in the right direction ๐Ÿ˜€

  • You must to post comments
0
0

You need to add fmodex_XX.lib or libfmodex.a to you linker options… Choose the lib that matches your compiler.

IN Visual Studio, I can’t remember where that darn thing is… Every time I need to add a lib it takes me hours to find it.

IN Dev-C++ it’s in Project/Project options/Paramiters/Add Library or Object

  • You must to post comments
0
0

that helped a bit, but here’s my output:
[code:fq7gsn1o]Compiling...
fmodtest.cpp
c:\documents and settings\owner\my documents\visual studio 2008\projects\fmodtest\fmodtest.cpp(55) : warning C4129: ‘ ‘ : unrecognized character escape sequence
c:\documents and settings\owner\my documents\visual studio 2008\projects\fmodtest\fmodtest.cpp(20) : warning C4101: ‘msg’ : unreferenced local variable
Linking...
fmodtest.obj : error LNK2019: unresolved external symbol "long stdcall WndProc(struct HWND *,unsigned int,unsigned int,long)" (?WndProc@@YGJPAUHWND__@@IIJ@Z) referenced in function _WinMain@16
MSVCRTD.lib(crtexe.obj) : error LNK2019: unresolved external symbol _main referenced in function ___tmainCRTStartup
C:\Documents and Settings\Owner\My Documents\programming\fmod\Debug\fmodtest.exe : fatal error LNK1120: 2 unresolved externals[/code:fq7gsn1o]

can you tell anything from that?

  • You must to post comments
0
0

just a visual C++ project with opengl and fmod would be awesome help

  • You must to post comments
0
0

there already is one of these, it is called ‘geometry’. It uses glut.

  • You must to post comments
0
0

yeah, but it has a console window too. and this game i’m adding fmod to doesn’t use glut, but if you [i:2rfp4e3u]need[/i:2rfp4e3u] glut to use fmod, then i’d like to know a way to do it without the console window

  • You must to post comments
0
0

I think you have something not set up correctly in your project settings.

You do not need glut for FMOD.

  • You must to post comments
0
0

yeah, i’m guessing so, i’m using visual c++ express

  • You must to post comments
0
0

all fixed, thanks everyone ๐Ÿ˜€

  • You must to post comments
Showing 8 results
Your Answer

Please first to submit.