0
0

In my program I use <EventSystem::setReverbProperties()> to set a global Reverb effect.
And then I load an event data to play.

Unfortunately, it doesn’t have any reverb effect.
But the sounds that I load by <System::createSound()> do have the reverb effect!

I check the event dry/wet volume in Fmod Designer, and make sure they are 0db.

How can I make the event dates response the Reverb sets?
Is there anything I miss on the code end? 😥

Thank you for any help you can give.

  • You must to post comments
0
0

I’m having the same issue. Though it’s not resolved yet you might want to check this to compare notes:
http://52.88.2.202/forum/viewtopic.php?t=9594

  • You must to post comments
0
0

I tested this with the simple event example

[quote:xgmw1362]
Please load up the ‘simple_event’ example in the fmod sdk.

Add
{
FMOD_REVERB_PROPERTIES prop = FMOD_PRESET_AUDITORIUM;

    result = eventsystem-&gt;setReverbProperties(&amp;prop);
    ERRCHECK(result);
}

Into the code in main.cpp (i just put it after getEvent) then run it, you should hear reverb.
Now compare this event and project with your own, are there any differences?
[/quote:xgmw1362]

  • You must to post comments
0
0

[quote="brett":3samszoq]I tested this with the simple event example

[quote:3samszoq]
Please load up the ‘simple_event’ example in the fmod sdk.

Add
{
FMOD_REVERB_PROPERTIES prop = FMOD_PRESET_AUDITORIUM;

    result = eventsystem-&gt;setReverbProperties(&amp;prop);
    ERRCHECK(result);
}

Into the code in main.cpp (i just put it after getEvent) then run it, you should hear reverb.
Now compare this event and project with your own, are there any differences?
[/quote:3samszoq][/quote:3samszoq]

Sincerele thanks for your great help, brett!

I compare the 2 project carefully and finally find the difference.

There is not any problem with the code end at all.

The only difference is in the Fmod Designer dates!
In Wave banks colume, one opinion is : Force software.
The default is "NO".

Of cource if you want to use the reverb preset of software, you have to change it to "Yes"!
That’s the key!

And I hope it to be helpful to those who meet the same problems.

  • You must to post comments
0
0

Setting "Force Software" to "Yes" for the wave banks in my project fixed my reverb issue as well. Thank you both for the insight! Perhaps this is worth a mention in the FMOD Designer Help for the Reverb tab? :)

  • You must to post comments
0
0

We’ll look at that for the docs, but with a creative soundcard or card that supports I3DL2 or EAX it would have worked.

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.