0
0

Hi There, I’m a bit new trying to add FMOD to my game, (based around adaptive audio, so kinda important) well I am looking at the the stream sound example and trying to implement it into my openGL application.

Adding these lines:
[quote:3bqem2hn]
result = FMOD::System_Create(&system);
ERRCHECK(result);[/quote:3bqem2hn] (this is me just trying to start putting the code in too :()
Causes a Link error:
[quote:3bqem2hn]Adaptive Audio error LNK2019: unresolved external symbol _FMOD_System_Create@4 referenced in function "enum FMOD_RESULT __cdecl FMOD::System_Create(class FMOD::System * *)" (?System_Create@FMOD@@YA?AW4FMOD_RESULT@@PAPAVSystem@1@@Z)
[/quote:3bqem2hn]

I have looked on the forum to similar problems – they did not help also looked at geometry example for ideas – also did not really help, I added a fmod lib file still with no effect. if any one can help me that would be great.

Michael

  • You must to post comments
0
0

had a little more of a play around – and looking on other forums… added this line in: [quote:29f9c9oa]#pragma comment(lib,"fmodexL_vc.lib")[/quote:29f9c9oa] then it compiles. but when i go to run the application a windows error message appears:

[quote:29f9c9oa]This application has failed to start because fmodexL.dll was not found. Re-installing the application may fix this problem.[/quote:29f9c9oa]

if anyone has idea it would be really helpful thanks :)

  • You must to post comments
0
0

did you put the fmod dll in the same directory as your executable? And are you sure you want the L (logging) version?

  • You must to post comments
0
0

[quote="brett":1f4xbp49]did you put the fmod dll in the same directory as your executable? And are you sure you want the L (logging) version?[/quote:1f4xbp49]

well i tried it without the L (logging version) and it ran… well way to try and put the rest of the code in now.

  • You must to post comments
0
0

Well the next error I had was putting in:
[quote:31loaucd] result = system->playSound(FMOD_CHANNEL_FREE, sound, false, &channel);
ERRCHECK(result);[/quote:31loaucd]

it did not like the & channel as it was converting parameters, but replaced &channel with a 0 and it worked! Thanks for your help. I’m way to get on with this project now. Hopefully will not be having too much trouble.

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.