0
0

Hi,

Is there any way at all to disable a speaker output while using an FMOD_3D sound?

I have a 5 speaker setup. I would like to have 3D sound going to 4 of these speakers. And I’d like to use the centre speakers which only has some narration.

The ideal way would be to have a FMOD_3D sound, and then being able to do

3dchannel->setSpeakerLevels(FRONT_CENTRE,{0},1);

However setSpeakerLevels doesn’t work fro FMOD_3D sounds. (Although the doco doesn’t explicitly say so, but testing it didn’t seem to work, and the similar function, setSpeakerMix is documented to only work for FMOD_2D sounds).

Is there any other way to effectively mute a channel from being played out of a specific speaker?

Thanks!

  • You must to post comments
0
0

look at System::set3DSpeakerPosition and the active flag.

  • You must to post comments
0
0

Thanks Brett!

For some reason I didn’t receive email notification for this, will need to make sure my address is correct…

Reason being if I knew about that 1 line of code I had to add, it would have saved me a few hours of my weekend where I implemented vector based amplitude panning myself! I did learn a lot in the process at least.

  • You must to post comments
0
0

you dont get emails about this, you should just check the revision.txt regularly for + or * type changes.

  • You must to post comments
0
0

Some confusion here,

When I set System::set3DSpeakerPosition active=false, it just excludes it from the 3D calculation, however it still plays the sound (i.e. as a 2D sound from that speaker).

Is there a way to specify a speaker does not play any 3D sounds?

  • You must to post comments
0
0

Ignore my last post. FMOD was disabling the speaker properly. Just happens that sub output was swapped with center speaker.

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.